Ask Your Question
0

heat : InternalServerError: Error: Internal Error

asked 2019-03-17 17:47:45 -0500

dimgr gravatar image

updated 2019-03-18 05:11:04 -0500

I have a dev setup of openstack ansible AIO with heat installed

heat is giving me an internal server error which i have pasted it in the link below because it is too big can someone take a look at it ? thanks

https://pastebin.com/rzbv6HHR

95.216.xxx is the public IP of this server running openstack

this is the log from heat.log when i actually enter heat commands such as openstack stack list

https://pastebin.com/FdS9w8AZ

here is the grep output for 95.216.244.168 from heat.conf

https://pastebin.com/CkYF60s8

does this make sense ?

edit retag flag offensive close merge delete

Comments

This is debug output from the openstack client. The openstack client sees that there is something wrong with Heat, but it can't look inside Heat. To understand what is wrong, you have to look at Heat's logs. Usually, they are found at /var/log/heat, but this may be different in OpenStack Ansible.

Bernd Bausch gravatar imageBernd Bausch ( 2019-03-18 01:25:10 -0500 )edit

Well, there is an interesting bit of information, namely that the connection to https://95.216.244.168:5000 fails since the TLS certificate can't be verified. Where does this address come from? Further up in the output, http://172.29.236.100:5000 is used.

Bernd Bausch gravatar imageBernd Bausch ( 2019-03-18 01:29:21 -0500 )edit

95.216.244.168 leads my browser to Horizon's login. However, the connection is redirected to https, then I am told that the site's certificate is incorrect.

I would grep this address in the Heat configuration.

Bernd Bausch gravatar imageBernd Bausch ( 2019-03-18 01:30:45 -0500 )edit

2 answers

Sort by » oldest newest most voted
0

answered 2019-03-18 05:50:01 -0500

dimgr gravatar image

updated 2019-03-18 06:03:39 -0500

hi

I do not use SSL certs . this server is going to be behind a vpn soon so no worries there

i solved the problem with heat . I replaced the public ip in heat conf with the private 172.xxxxx which is the ip for br-mgmt interface , restarted the heat container and the problem went away

actual heat commands like openstack stack list now show nothing and this is normal

i did not actually enter the public IP in the heat conf , it was entered by the openstack ansible role so i guess i must find a way to tell it not to use the public ip if this is possible

edit flag offensive delete link more
0

answered 2019-03-18 05:16:25 -0500

updated 2019-03-18 05:26:28 -0500

The log doesn’t show the messages at the time the error occurs. But I am convinced that the problem is the invalid certificate at 95.216.244.168. Either correct/renew the certificate, or don’t use https in the config file.

TLS configuration is documented at https://docs.openstack.org/project-de..., though this is for Pike. I didn’t find the equivalent page for Rocky.

Also, since you have a private IP, why don’t you use it for communication internal to the cloud?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2019-03-17 17:47:45 -0500

Seen: 38 times

Last updated: Mar 18