cant connect to server

asked 2019-03-15 02:12:59 -0500

ankur13.sharma gravatar image

we successfully installed openstack on ubuntu setup and in this setup all the containers are connected to deployment host password less. but in centos setup first two playbook executed successfully containers are created as well, but while executing third playbook it is showing this error

PLAY [Prepare MQ/DB services] *********************************** TASK [Ensure Rabbitmq vhost] *********************************** Thursday 14 March 2019 11:20:34 +0530 (0:00:00.087) 0:00:00.087 * ok: [centos-infra_keystone_container-* -> ip of container] TASK [Ensure rabbitmq user] *********************************** Thursday 14 March 2019 11:20:36 +0530 (0:00:01.765) 0:00:01.852 * ok: [centos-infra keystone_container-*-> ip of container] TASK [Ensure Rabbitmq vhost] *********************************** Thursday 14 March 2019 11:20:38 +0530 (0:00:02.215) 0:00:04.067 * TASK [Ensure rabbitmq user] *********************************** Thursday 14 March 2019 11:20:38 +0530 (0:00:00.028) 0:00:04.095 * TASK [Create DB for service] *********************************** Thursday 14 March 2019 11:20:38 +0530 (0:00:00.031) 0:00:04.127 * fatal: [centos-infra_keystone_container-*-> ip of container]: FAILED! => {"changed": false, "failed": true, "msg": "unable to connect to database, check login_user and login_password are correct or /root/.my.cnf has the credentials. Exception message: (2003, 'Can\'t connect to MySQL server on \'ip of lb\' (113 \"No route to host\")')"} NO MORE HOSTS LEFT ******************

containers are pinging from deployment host but not ssh pingable

[root@centos-deploy1 openstack_deploy]# ping 172.16.52.221 PING 172.16.52.221 (172.16.52.221) 56(84) bytes of data. 64 bytes from 172.16.52.221: icmp_seq=1 ttl=64 time=0.304 ms 64 bytes from 172.16.52.221: icmp_seq=2 ttl=64 time=0.138 ms --- 172.16.52.221 ping statistics --- 2 packets transmitted, 2 received, 0% packet loss, time 1000ms rtt min/avg/max/mdev = 0.138/0.221/0.304/0.083 ms [root@centos-deploy1 openstack_deploy]# ssh 172.16.52.221 ssh: connect to host 172.16.52.221 port 22: No route to host

i guess deployment host should be connected to containers password less through ssh

edit retag flag offensive close merge delete

Comments

Which deployment tool are you using?

Ping is not sufficient as a test. It only shows that you have connectivity to the host. You need connectivity to the database, so check if you can access port 3306.

Since you mention Centos, I wonder if you need to manually open ports in the Centos firewall.

Bernd Bausch gravatar imageBernd Bausch ( 2019-03-15 04:38:05 -0500 )edit

I just notice that you also don't have ssh access to 172.16.52.221. Centos leaves port 22 open by default, but your test results indicate that it's closed.

Bernd Bausch gravatar imageBernd Bausch ( 2019-03-15 04:40:50 -0500 )edit