Ask Your Question
0

Please specify data store No default data store is defined

asked 2019-03-08 03:13:57 -0500

Sibasankar gravatar image

Hi Openstack, We are trying to make trove database instance in devstack rocky, but we are getting error. Please find below the error details.

COMMAND:- trove create my-inst a51184af-9646-4f86-8978-0edaa955502d --size 100 --volume_type lvmdriver-1

ERROR: Please specify datastore. No default datastore is defined. (HTTP 400)

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2019-03-11 05:33:14 -0500

Sibasankar gravatar image

Hi,

We go through the above link and we are gating error. Please find below the error.

trove create mysql_instance_1 6 --size 50 --databases mysqlDB --users dbuser:mydb123 --datastore_version mysql-5.5 --datastore mysql

ERROR: Validation error: instance['volume']['type'] None is not of type 'string' (HTTP 400)

edit flag offensive delete link more

Comments

I suggest you ask a new question rather than asking your question in an answer.

Bernd Bausch gravatar imageBernd Bausch ( 2019-03-11 09:04:33 -0500 )edit

Well it looks something is wrong with your Cinder setup. See the Cinder tests at https://docs.openstack.org/trove/late....

Bernd Bausch gravatar imageBernd Bausch ( 2019-03-11 09:08:28 -0500 )edit
0

answered 2019-03-08 06:08:46 -0500

You need the --datastore option. See https://docs.openstack.org/trove/late....

The message implies that it might be possible to configure a default datastore. I have not spent enough time to find out how to do that.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-03-08 03:13:57 -0500

Seen: 18 times

Last updated: Mar 11