Ask Your Question
0

barbican installation on rocky - not working

asked 2019-03-07 12:40:04 -0500

stef97 gravatar image

Hi,

I have installed barbican using official documentation https://docs.openstack.org/barbican/latest/install/verify.html (https://docs.openstack.org/barbican/l...)

Everything went fine except that the no one is listening on port 9311 There is no log file in /var/log/barbican and nothing useful httpd logs ( except complains that SSL is disabled)

endpoints are correct ( no versioning at the end)

I must be missing something really simple/basic as there are not too many people having installation issues

Any hints how to troubleshoot this will be appreciated

openstack secret store --name mysecret --payload j4=]d21 Failed to contact the endpoint at http://10.10.30.158:9311 for discovery. Fallback to using that endpoint as the base url.

openstack endpoint list | grep barbican | 20c900918bc74f2794a21b671ff2fb84 | RegionOne | barbican | key-manager | True | internal | http://10.10.30.158:9311

/etc/barbican/barbican.conf

[DEFAULT] host_href = http://10.10.30.158:9311 sql_connection = mysql+pymysql://barbican:@10.10.30.158/barbican db_auto_create = false debug = true transport_url=rabbit://guest:guest@10.10.30.158:5672/ [certificate] [certificate_event] [cors] [crypto] [dogtag_plugin] [keystone_authtoken] www_authenticate_uri=http://10.10.30.158:5000/v3 memcached_servers=10.10.30.158:11211 auth_type=password auth_url=http://10.10.30.158:5000 username=barbican password=* user_domain_name=Default project_name=services project_domain_name=Default

Thanks

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2019-03-07 13:24:02 -0500

stef97 gravatar image

Hi, I've used this and it is working now https://www.server-world.info/en/note?os=CentOS_7&p=openstack_ocata2&f=18 (https://www.server-world.info/en/note...)

barbican is working fine as a service - not sure why the docs suggested to added to Apache

edit flag offensive delete link more

Comments

One has to add Listen 9311 to apache conf

jsm gravatar imagejsm ( 2019-03-09 09:10:56 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-03-07 12:40:04 -0500

Seen: 28 times

Last updated: Mar 07