Ask Your Question
0

magnum fedora-atomic no available network renderers found

asked 2019-03-05 15:01:11 -0500

stef97 gravatar image

updated 2019-03-06 19:58:57 -0500

Hi, I have been struggling getting kubernetes cluster deployed using magnum and the cluster timeout I noticed below in the cloud-init-output.log of the deployed minion/master

"stages.py[ERROR]: Unable to render networking. Network config is likely broken: No available network renderers found. Searched through list: ['eni', 'sysconfig', 'netplan'] ."

I am using latest fedora-atomic ( version 29, which has cloun-init version 17.1) and openstack rocky

I was thinking of trying a different image but before I go that route I am hoping someone can either suggest an image that works or a way to fix current one

Any help/hint would be greatly appreciated.

Thanks for taking the trouble to respond Using Fedora-AtomicHost-28-20180806.0.x86_64.qcow2 got rid of the network issue but I am running into a certificate one now " creating self-signed certificates: open /var/run/kubernetes/apiserver.crt: permission denied" Looks like there are a few documented bugs about it https://bugs.launchpad.net/ubuntu/+so... (https://bugs.launchpad.net/ubuntu/+so...) https://bugs.launchpad.net/magnum/+bu... (https://bugs.launchpad.net/magnum/+bu...)

any ideas / suggestions will be appreciated Note Ill try to start a cluster with TLS enabled

Steven

edit retag flag offensive close merge delete

Comments

Perhaps this bug? https://pagure.io/cloud-sig/issue/289.

If so you may need a newer Fedora image.

Bernd Bausch gravatar imageBernd Bausch ( 2019-03-05 18:02:59 -0500 )edit

Sorry I am not better than Google as far as the certificate error is concerned.

Bernd Bausch gravatar imageBernd Bausch ( 2019-03-06 20:02:00 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2019-03-07 15:55:29 -0500

stef97 gravatar image

I have been unable to make it work with TLS enabled The error message from master cloud-init is "waiting for CA to be made available for certificate manager api"

I tried both barbican and local with the same result I also added 'cert_manager_api=true' label to the template

All I want is a kubernetes cluster so if anyone is aware of a winning combination between fedora-atomic version and magnum with/without TLS it will be really appreciated if they can share their knowledge / config files

edit flag offensive delete link more

Comments

I was able to have this working after I added "region_name_for_services = RegionOne" to heat.conf I tested it only with local certificates

stef97 gravatar imagestef97 ( 2019-03-10 07:59:33 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-03-05 15:01:11 -0500

Seen: 138 times

Last updated: Mar 07