DevStack installation failure,call for help!

asked 2019-03-03 07:10:41 -0500

Samuel_Kangabear gravatar image

I am new to OpenStack and attempt to set up the lab environment for further study. My installation was based on the official recommended ubuntu 16.04, followed the document https://docs.openstack.org/devstack/latest/ (https://docs.openstack.org/devstack/l...). The process was interrupted , display the following error information:

 +functions-common:is_service_enabled:1939  local xtrace
++functions-common:is_service_enabled:1940  grep xtrace
++functions-common:is_service_enabled:1940  set +o
+functions-common:is_service_enabled:1940  xtrace='set -o xtrace'
+functions-common:is_service_enabled:1941  set +o xtrace
+functions-common:is_service_enabled:1969  return 0
+lib/cinder:create_volume_types:539        openstack --os-region-name=RegionOne volume type create --property volume_backend_name=lvmdriver-1 lvmdriver-1
Internal Server Error (HTTP 500)
+lib/cinder:create_volume_types:1          exit_trap
+./stack.sh:exit_trap:522                  local r=1
++./stack.sh:exit_trap:523                  jobs -p
+./stack.sh:exit_trap:523                  jobs=
+./stack.sh:exit_trap:526                  [[ -n '' ]]
+./stack.sh:exit_trap:532                  '[' -f /tmp/tmp.gXvKpFsRPi ']'
+./stack.sh:exit_trap:533                  rm /tmp/tmp.gXvKpFsRPi
+./stack.sh:exit_trap:537                  kill_spinner
+./stack.sh:kill_spinner:432               '[' '!' -z '' ']'
+./stack.sh:exit_trap:539                  [[ 1 -ne 0 ]]
+./stack.sh:exit_trap:540                  echo 'Error on exit'
Error on exit
+./stack.sh:exit_trap:542                  type -p generate-subunit
+./stack.sh:exit_trap:543                  generate-subunit 1551530639 2641 fail
+./stack.sh:exit_trap:545                  [[ -z /opt/stack/logs ]]
+./stack.sh:exit_trap:548                  /opt/stack/devstack/tools/worlddump.py -d /opt/stack/logs
World dumping... see /opt/stack/logs/worlddump-2019-03-0    2-132802.txt for details
neutron-dhcp-agent: no process found
neutron-l3-agent: no process found
neutron-metadata-agent: no process found
neutron-openvswitch-agent: no process found
+./stack.sh:exit_trap:557                  exit 1
stack@ubuntu:~/devstack$ 

Meanwhile I reviewed the log file , it notified that:


*** Failed to run 'killall -e -USR2 neutron-dhcp-agent': Command 'killall -e -USR2 neutron-dhcp-agent' returned non-zero exit status 1
guru meditation report in neutron-dhcp-agent log

neutron-l3-agent Guru Meditation Report
=======================================

22978
killall -e -USR2 neutron-l3-agent
---------------------------------

*** Failed to run 'killall -e -USR2 neutron-l3-agent': Command 'killall -e -USR2 neutron-l3-agent' returned non-zero exit status 1
guru meditation report in neutron-l3-agent log

neutron-linuxbridge-agent Guru Meditation Report
================================================

Skipping as neutron-linuxbridge-agent does not appear to be running

neutron-metadata-agent Guru Meditation Report
=============================================

23560
24152
24153
killall -e -USR2 neutron-metadata-agent
---------------------------------------

*** Failed to run 'killall -e -USR2 neutron-metadata-agent': Command 'killall -e -USR2 neutron-metadata-agent' returned non-zero exit status 1
guru meditation report in neutron-metadata-agent log
Type  :quit<enter>  to exit Vim                                  827,5         97%
edit retag flag offensive close merge delete

Comments

It's probably not Neutron but Cinder that has a problem. See the openstack volume create command at the beginning of the stack.sh output you are sharing.

Devstack's Cinder backend is LVM. The physical volume is a loop-mounted file. Could it be that you don't have enough storage space?

Bernd Bausch gravatar imageBernd Bausch ( 2019-03-03 07:44:44 -0500 )edit

You can also check Cinder's API log sudo journalctl -u devstack@cinder-api.

Bernd Bausch gravatar imageBernd Bausch ( 2019-03-03 07:45:26 -0500 )edit

I followed your idea to resize the storage, it failed again by the problem you mentioned: the c-api did not start.


[Call Trace]
./stack.sh:1343:start_cinder
/opt/stack/devstack/lib/cinder:510:die
[ERROR] /opt/stack/devstack/lib/cinder:510 c-api did not start
Samuel_Kangabear gravatar imageSamuel_Kangabear ( 2019-03-03 22:16:07 -0500 )edit

as I intend to check the Cinder's API log, it presents no entries.

Samuel_Kangabear gravatar imageSamuel_Kangabear ( 2019-03-03 22:16:45 -0500 )edit

I gave you a typo. The service is named c-api, and therefore you read the log with sudo journalctl -u devstack@c-api.

Bernd Bausch gravatar imageBernd Bausch ( 2019-03-03 23:59:44 -0500 )edit