Ask Your Question
0

nova-api did not start

asked 2019-02-28 09:20:38 -0500

Henry gravatar image

Dear community, since days I try to install devstack and run into several issues. So far I tried both: Ubuntu 16.04 LTS (minimal) and Ubuntu 18.04 LTS. I run this as a VM in an ESX Server (ESXi-6.5.0-2017010400).

The first error which in all cases happens is the following one:

Waiting for nova-api to start...
+lib/nova:start_nova_api:884               wait_for_service 60 http://10.10.0.47/compute/v2.1/
+functions:wait_for_service:427            local timeout=60
+functions:wait_for_service:428            local url=http://10.10.0.47/compute/v2.1/
+functions:wait_for_service:429            local rval=0
+functions:wait_for_service:430            time_start wait_for_service
+functions-common:time_start:2303          local name=wait_for_service
+functions-common:time_start:2304          local start_time=
+functions-common:time_start:2305          [[ -n '' ]]
++functions-common:time_start:2308          date +%s%3N
+functions-common:time_start:2308          _TIME_START[$name]=1551235486702
+functions:wait_for_service:431            timeout 60 bash -x
++::                                        curl -g -k --noproxy '*' -s -o /dev/null -w '%{http_code}' http://10.10.0.47/compute/v2.1/
+functions:wait_for_service:431            rval=124
+functions:wait_for_service:436            time_stop wait_for_service
+functions-common:time_stop:2317           local name
+functions-common:time_stop:2318           local end_time
+functions-common:time_stop:2319           local elapsed_time
+functions-common:time_stop:2320           local total
+functions-common:time_stop:2321           local start_time
+functions-common:time_stop:2323           name=wait_for_service
+functions-common:time_stop:2324           start_time=1551235486702
+functions-common:time_stop:2326           [[ -z 1551235486702 ]]
++functions-common:time_stop:2329           date +%s%3N
+functions-common:time_stop:2329           end_time=1551235547383
+functions-common:time_stop:2330           elapsed_time=60681
+functions-common:time_stop:2331           total=40574
+functions-common:time_stop:2333           _TIME_START[$name]=
+functions-common:time_stop:2334           _TIME_TOTAL[$name]=101255
+functions:wait_for_service:437            return 124
+lib/nova:start_nova_api:885               die 885 'nova-api did not start'
+functions-common:die:195                  local exitcode=0
+functions-common:die:196                  set +o xtrace
[Call Trace]
./stack.sh:1294:start_nova_api
/opt/stack/devstack/lib/nova:885:die
[ERROR] /opt/stack/devstack/lib/nova:885 nova-api did not start
Error on exit
World dumping... see /opt/stack/logs/worlddump-2019-02-27-024553.txt for details

On the first view this looks like a timeout issue, but if I manually run:

curl -g -k --noproxy '*' -s -o /dev/null -w '%{http_code}' http://10.10.0.47/compute/v2.1/

Then I get a 401 (not authorized) as a response. Searching for others which ran into similar issues revealed that usually this is resolved after restarting the system or use unstack.sh / clean.sh and then stack.sh again. Actually this is true and the nova-api error goes away, but then there are other issues and I'm concerned that nova-api is related to this. Maybe I'm wrong.

I would like to address this step by step to get to a clean install. The next issue is that g-api also doesn't start which is extremely odd because before running stack.sh I can execute the test which times out after 60 seconds but if I run stack.sh again, then the service is not reachable again. Restarting the system allows me to access it. Extremely odd.

Thank you very much for your help.

PS: Here my local.conf:

[[local|localrc]]
ADMIN_PASSWORD=XXXXXXX
DATABASE_PASSWORD=$ADMIN_PASSWORD
RABBIT_PASSWORD=$ADMIN_PASSWORD
SERVICE_PASSWORD=$ADMIN_PASSWORD
edit retag flag offensive close merge delete

Comments

When nova-api doesn't start, it should leave a few messages in its log that should help you. Devstack uses systemd and journald, so check this out:

journalctl -u devstack@nova-api
Bernd Bausch gravatar imageBernd Bausch ( 2019-02-28 18:27:41 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2019-03-08 00:25:31 -0500

Henry gravatar image

Hello Bernd, thank you very much for your help. Sorry for my late response. The reason is that I never ran into the same issue again when I started to do the installation not on my slow esx server, but on my much faster desktop pc using vmware desktop. So I bypassed this issue by creating the vm on my desktop first and then with vmware converter, I uploaded the vm to the slow esx server as a new vm. That way I can get to a complete installation and run the dashboard. If someone has the same issue with a slow installation vm - you just have to also keep in mind that devstack will store the assigned IP address at many places.

So in my case, the ip address comes from the dhcp server within my dsl router. I simply bound first the ip of the installation vm to one IP and then after transfering that vm to esx (other mac address), I bound the same IP to that mac address instead.

The main issue really seems to be on slow systems during installation. It would be great if a timeout can be adjusted, but I did not find any way to do so. I can imagine that someone will wonder "if the system is that slow why would someone even want to work with that?" and the answer is - regression and integration test. I don't care if that works slowly or not as long as I get in the end some report that a push broke something.

edit flag offensive delete link more

Comments

Perhaps you can set a timeout. After all, the Devstack installer is a bunch of shell scripts. But first, we would need to know why it breaks.

Devstack was actually written for testing. It is used in the OpenStack CI environment to automatically set up test systems.

Bernd Bausch gravatar imageBernd Bausch ( 2019-03-08 03:06:26 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-02-28 09:20:38 -0500

Seen: 333 times

Last updated: Feb 28 '19