Queens network isolation deployment failed. Overcloud nodes get only the provisioning IP address

asked 2019-02-26 21:08:49 -0500

jm gravatar image

I'm currently deploying openstack queens using triple0 deployment method with 3 controllers and 1 compute. I alway having a failed deployment and I noticed that all overcloud nodes only receive the provisioning IP. No vlan interface and Ip address assigned for Internal, External, Storage and Tenat network.

Deployment command:openstack overcloud deploy --templates -e ~/generated-openstack-tripleo-heat-templates/environments/network-isolation.yaml -e ~/generated-openstack-tripleo-heat-templates/environments/network-environment.yaml -e ~/templates/network-environment-overrides.yaml -e ~/templates/node-info.yaml --ntp-server http://pool.ntp.org --timeout 90

Also tried to used ovs_bridge and linux_bridge but will same output error.

Controller.yamlhttp://paste.openstack.org/show/746381/

Compute.yamlhttp://paste.openstack.org/show/746382/

network-environment-overrides.yamlhttp://paste.openstack.org/show/746383/

network-isolation.yamlhttp://paste.openstack.org/show/746384/

edit retag flag offensive close merge delete

Comments

I had a similar problem recently. Which I have now resolved. Can you post your network environment file? Have you tried taking out the overrides file and redeploying?

d4c07 gravatar imaged4c07 ( 2019-02-27 12:40:12 -0500 )edit

how did you resolved? can you share your deployment command?

jm gravatar imagejm ( 2019-03-04 21:03:27 -0500 )edit

Here my network-environment file

http://paste.openstack.org/show/747268/

jm gravatar imagejm ( 2019-03-04 21:12:31 -0500 )edit

Also tried to redeploy without the overrides template but still got the same error

jm gravatar imagejm ( 2019-03-05 09:28:32 -0500 )edit