Ask Your Question
0

Kolla-ansible unable to start memcached?

asked 2019-02-21 04:43:37 -0500

sean.xyz gravatar image

I have deployed OpenStack using kolla-ansible. And, memcached service is unable to start and keep on restarting.

# docker logs mecached
sudo -E kolla_set_configs
INFO:__main__:Loading config file at /var/lib/kolla/config_files/config.json
INFO:__main__:Validating config file
INFO:__main__:Kolla config strategy set to: COPY_ALWAYS
INFO:__main__:Copying service configuration files
INFO:__main__:Writing out command to execute
++ cat /run_command
+ CMD='/usr/bin/memcached -v -l 10.121.2.124 -p 11211 -c 5000 -U 0 -m 256'
+ ARGS=
+ [[ ! -n '' ]]
+ . kolla_extend_start
+ echo 'Running command: '\''/usr/bin/memcached -v -l 10.121.2.124 -p 11211 -c 5000 -U 0 -m 256'\'''
Running command: '/usr/bin/memcached -v -l 10.121.2.124 -p 11211 -c 5000 -U 0 -m 256'
+ exec /usr/bin/memcached -v -l 10.121.2.124 -p 11211 -c 5000 -U 0 -m 256
failed to set rlimit for open files. Try starting as root or requesting smaller maxconns value.
edit retag flag offensive close merge delete

Comments

Info distro, version user running?

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2019-02-21 09:52:45 -0500 )edit

I was using master/rocky branch of kolla-ansible, with openstack_version being set to master.

sean.xyz gravatar imagesean.xyz ( 2019-02-21 20:02:12 -0500 )edit

Need to use for both rocky, however i dont think in this case the error is from that. Is likely a permission or ulimit config in the host

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2019-02-22 01:39:02 -0500 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2019-02-24 20:05:12 -0500

sean.xyz gravatar image

I am answering my own question. The problem seems to be related to ulimit.(https://github.com/TelegramMessenger/MTProxy/issues/7 (source)) However, there is no API for setting ulimit in kolla-ansible in all current releases, and only after this commit in master https://github.com/openstack/kolla-ansible/commit/da98030909dab2b3f3119b9f695dda0231995b35 (branch).

So, I have solved the prolem by checking to that commit, and add the following config /etc/kolla/globals.yml.

memcached_dimensions:
  ulimits:
    nofile:
      soft: 98304
      hard: 98304
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-02-21 04:43:37 -0500

Seen: 80 times

Last updated: Feb 21