ceph error during overcloud deploy [closed]

asked 2019-02-18 14:32:11 -0500

valvi gravatar image

Hi all, I'm trying to deploy my own cloud using TripleO in HCI setup.

Openstack version: rocky docker.io/ceph/daemon:v3.2.0-stable-3.2-luminous-centos-7-x86_64 ceph version: 12.2.9

When I try to deploy mi plan I had this error:

ceph-volume lvm batch: error: unrecognized arguments: --prepare

Below detailed log error:

"Monday 18 February 2019 20:19:51 +0100 (0:00:00.432) 0:17:47.881 * ", "included: /usr/share/ceph-ansible/roles/ceph-osd/tasks/scenarios/lvm-batch.yml for overcloud-osdcompute-2, overcloud-osdcompute-0, overcloud-osdcompute-1", "TASK [ceph-osd : use ceph-volume lvm batch to create bluestore osds] **", "Monday 18 February 2019 20:19:52 +0100 (0:00:00.892) 0:17:48.774 ** ", "fatal: [overcloud-osdcompute-1]: FAILED! => {\"changed\": true, \"cmd\": [\"docker\", \"run\", \"--rm\", \"--privileged\", \"--net=host\", \"-v\", \"/run/lock/lvm:/run/lock/lvm:z\", \"-v\", \"/dev:/dev\", \"-v\", \"/etc/ceph:/etc/ceph:z\", \"-v\", \"/run/lvm/lvmetad.socket:/run/lvm/lvmetad.socket\", \"-v\", \"/var/lib/ceph/:/var/lib/ceph/:z\", \"-v\", \"/var/log/ceph/:/var/log/ceph/:z\", \"--entrypoint=ceph-volume\", \"docker.io/ceph/daemon:v3.2.0-stable-3.2-luminous-centos-7-x86_64\", \"--cluster\", \"ceph\", \"lvm\", \"batch\", \"--bluestore\", \"--yes\", \"--prepare\", \"--dmcrypt\", \"/dev/sdb\", \"/dev/sdc\", \"/dev/sdd\", \"/dev/sde\", \"/dev/sdf\", \"/dev/sdg\", \"/dev/sdh\", \"/dev/sdi\", \"/dev/sdj\", \"/dev/sdk\", \"/dev/sdl\", \"/dev/sdm\", \"--report\", \"--format=json\"], \"msg\": \"non-zero return code\", \"rc\": 2, \"stderr\": \"usage: ceph-volume lvm batch [-h] [--bluestore] [--filestore] [--report]\ [--yes] [--format {json,pretty}] [--dmcrypt]\ [--crush-device-class CRUSH_DEVICE_CLASS]\ [--no-systemd]\ [--osds-per-device OSDS_PER_DEVICE]\ [--block-db-size BLOCK_DB_SIZE]\ [--journal-size JOURNAL_SIZE]\ [DEVICES [DEVICES .. .]]\ ceph-volume lvm batch: error: unrecognized arguments: --prepare\", \"stderr_lines\": [\"usage: ceph-volume lvm batch [-h] [--bluestore] [--filestore] [--report]\", \"[--yes] [--format {json,pretty}] [--dmcrypt]\", \"[--crush-device-class CRUSH_DEVICE_CLASS]\", \"[--no-systemd]\", \"[--osds-per-device OSDS_PER_DEVICE]\", \"[--block-db-size BLOCK_DB_SIZE]\", \"[--journal-size JOURNAL_SIZE]\", \"[DEVICES [DEVICES ...]]\", \"ceph-volume lvm batch: error: unrecognized arguments: --prepare\"], \"stdout\": \"\", \"stdout_lines\": []}",

"fatal: [overcloud-osdcompute-0]: FAILED! => {\"changed\": true, \"cmd\": [\"docker\", \"run\", \"--rm\", \"--privileged\", \"--net=host\", \"-v\", \"/run/lock/lvm:/run/lock/lvm:z\", \"-v\", \"/dev:/dev\", \"-v\", \"/etc/ceph:/etc/ceph:z\", \"-v\", \"/run/lvm/lvmetad.socket:/run/lvm/lvmetad.socket\", \"-v\", \"/var/lib/ceph/:/var/lib/ceph/:z\", \"-v\", \"/var/log/ceph/:/var/log/ceph/:z\", \"--entrypoint=ceph-volume\", \"docker.io/ceph/daemon:v3.2.0-stable-3.2-luminous-centos-7-x86_64\", \"--cluster\", \"ceph\", \"lvm\", \"batch\", \"--bluestore\", \"--yes\", \"--prepare\", \"--dmcrypt\", \"/dev/sdb\", \"/dev/sdc\", \"/dev/sdd\", \"/dev/sde\", \"/dev/sdf\", \"/dev/sdg\", \"/dev/sdh\", \"/dev/sdi\", \"/dev/sdj\", \"/dev/sdk\", \"/dev/sdl\", \"/dev/sdm\", \"--report\", \"--format=json\"], \"msg\": \"non-zero return code\", \"rc\": 2, \"stderr\": \"usage: ceph-volume lvm batch [-h] [--bluestore] [--filestore] [--report]\ [--yes] [--format {json,pretty}] [--dmcrypt]\ [--crush-device-class CRUSH_DEVICE_CLASS]\ [--no-systemd]\ [--osds-per-device OSDS_PER_DEVICE]\ [--block-db-size BLOCK_DB_SIZE]\ [--journal-size JOURNAL_SIZE]\ [DEVICES [DEVICES ...]]\ ceph-volume lvm batch: error: unrecognized arguments: --prepare\", \"stderr_lines\": [\"usage: ceph-volume lvm batch [-h] [--bluestore] [--filestore] [--report]\", \"[--yes] [--format {json,pretty}] [--dmcrypt]\", \"[--crush-device-class CRUSH_DEVICE_CLASS]\", \"[--no-systemd]\", \"[--osds-per-device OSDS_PER_DEVICE]\", \"[--block-db-size BLOCK_DB_SIZE]\", \"[--journal-size JOURNAL_SIZE]\", \"[DEVICES [DEVICES ...]]\", \"ceph-volume lvm batch: error: unrecognized arguments: --prepare\"], \"stdout\": \"\", \"stdout_lines\": []}",

"fatal: [overcloud-osdcompute-2]: FAILED! => {\"changed\": true, \"cmd\": [\"docker\", \"run\", \"--rm\", \"--privileged\", \"--net=host\", \"-v\", \"/run/lock/lvm:/run/lock/lvm:z\", \"-v\", \"/dev:/dev\", \"-v\", \"/etc/ceph:/etc/ceph:z\", \"-v\", \"/run/lvm/lvmetad.socket:/run/lvm/lvmetad.socket\", \"-v\", \"/var/lib/ceph/:/var/lib/ceph/:z\", \"-v\", \"/var/log ... (more)

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by valvi
close date 2019-03-05 03:16:42.424894

Comments

Have you tried to execute the ceph-volume command manually? The --prepare option is recognized in my Luminous cluster (12.2.10). But IIRC the 12.2.9 release you seem to be using was a very bad one. Do you have the option to use a later release? 12.2.11 has been released recently.

eblock gravatar imageeblock ( 2019-02-19 02:45:30 -0500 )edit

Hi, thansk or youre reply. I've tried to execute ceph-volume manually but the error it's the same, if I remove th "--prepare" option it works. I can use also the latest release, but how I can do that with tripleo? I need to specify it in some configuration file?

valvi gravatar imagevalvi ( 2019-02-19 04:27:54 -0500 )edit

Unfortunately, I don't have experience with tripleo so I don't have an answer to that.

eblock gravatar imageeblock ( 2019-02-20 03:32:29 -0500 )edit

I've just rebuilded the image for overcloud, now it works

valvi gravatar imagevalvi ( 2019-03-05 03:17:24 -0500 )edit