Ask Your Question
0

DHCP not working in VLAN subinterfaces

asked 2019-02-08 05:03:41 -0500

PTcrusher gravatar image

I have a fresh install of RDO (Rocky) all-in-one in a CentOS Linux release 7.6.1810 (Core). Unfortunately i'm not being able to get a DHCP assigned IP address when connected through br-vlan.300 interface.

public network ------ | R1 | ------- private_network (GW 192.168.2.1)
                      |    | ------- management_network (VLAN 300 GW 192.168.3.254)
                      |    | ------- storage_network (VLAN 400 GW 192.168.4.254)

The GWs of the management and storage network are not the default .1 ones because .1 was taken by a static address provisioned in Openstack (this was due to some testing where the GW for these networks was a pfsense instance).

Moving on, the host server has two NICs eno1 which is linked to the bridge br-ex (public network) and enp2s0 which is linked to br-vlan. The enp2s0 interface is linked to a physicall switch via a trunk interface, the DHCP Requests are coming from a machine connected to an access port of this physicall switch.

Packet captures show the DHCP request but no response from the DHCP server. If i set the IP manually on the source of the DHCP request i can ping the IP of the DHCP server and the GW.

[edsa@openstack ~(keystone_admin)]$ ip netns
qrouter-b7bd349b-b4e2-4fbf-9567-cf2ff680242b (id: 2)
qdhcp-0b05bf9d-ed96-4b3c-b00d-9fc624465e3f (id: 1)

[edsa@openstack ~(keystone_admin)]$ sudo ip netns exec qrouter-b7bd349b-b4e2-4fbf-9567-cf2ff680242b ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
13: qr-04897fa0-c7: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1450 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/ether fa:16:3e:ba:ed:d3 brd ff:ff:ff:ff:ff:ff
14: qr-11412e39-f6: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/ether fa:16:3e:d6:35:53 brd ff:ff:ff:ff:ff:ff
15: **qr-c56c14f7-22**: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/ether fa:16:3e:03:cc:38 brd ff:ff:ff:ff:ff:ff
16: qg-3749cea5-17: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/ether fa:16:3e:d1:ad:9d brd ff:ff:ff:ff:ff:ff

[edsa@openstack ~(keystone_admin)]$ sudo ip netns exec qrouter-b7bd349b-b4e2-4fbf-9567-cf2ff680242b tcpdump -nni qr-c56c14f7-22 port 67 or port 68
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on qr-c56c14f7-22, link-type EN10MB (Ethernet), capture size 262144 bytes
10:33:56.892301 IP 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from d4:be:d9:3f:91:48, length 300
10:34:00.766967 IP 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from d4:be:d9:3f:91:48, length 300

[edsa@openstack ~(keystone_admin)]$ sudo ip netns exec qdhcp-0b05bf9d-ed96-4b3c-b00d-9fc624465e3f ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000 ...
(more)
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2019-02-13 20:08:55 -0500

PTcrusher gravatar image

Think i got it... you just need to create a port with the MAC address of your PHY device, otherwise it will never get an DHCP offer. Thats the way dnsmask is set.

https://openstack.nimeyo.com/75512/openstack-dhcp-external-device-from-openstack-tenant-network (Source)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-02-08 05:03:41 -0500

Seen: 119 times

Last updated: Feb 13