NeutronAdminCredentialConfigurationInvalid raised when 'Launch instance'

asked 2019-02-08 03:07:43 -0500

binooetomo gravatar image

updated 2019-02-08 23:18:28 -0500

Dear All ...

I got nova error about 'NeutronAdminCredentialConfigurationInvalid'.

What I do is, login to horizon as admin, and try to create an instance.

Here is from /var/log/nova/nova-api.log right after I click 'launch instance' button.

2019-02-08 15:56:16.138 19148 INFO nova.osapi_compute.wsgi.server [req-914666f9-5a2d-4323-9f92-515276f75565 69a638fb9e5d4788b6f23d67180f85da 2568b941b3a54c13b57c930fe3805d3c - default default] 127.0.0.1 "GET /v2.1 HTTP/1.0" status: 302 len: 300 time: 3.1299040



2019-02-08 15:56:19.252 19148 INFO nova.osapi_compute.wsgi.server [req-a53933c1-f157-4c24-ab87-5f5b14839e84 69a638fb9e5d4788b6f23d67180f85da 2568b941b3a54c13b57c930fe3805d3c - default default] 127.0.0.1 "GET /v2.1/ HTTP/1.0" status: 200 len: 771 time: 3.1098912





2019-02-08 15:56:39.069 19147 ERROR nova.network.neutronv2.api [req-bc73b885-bab4-4116-8497-96bbe782ea4d 69a638fb9e5d4788b6f23d67180f85da 2568b941b3a54c13b57c930fe3805d3c - default default] Neutron client was not able to generate a valid admin token, please verify Neutron admin credential located in nova.conf: Unauthorized: 401-{u'error': {u'message': u'The request you have made requires authentication.', u'code': 401, u'title': u'Unauthorized'}}
2019-02-08 15:56:39.070 19147 ERROR nova.api.openstack.wsgi [req-bc73b885-bab4-4116-8497-96bbe782ea4d 69a638fb9e5d4788b6f23d67180f85da 2568b941b3a54c13b57c930fe3805d3c - default default] Unexpected exception in API method: NeutronAdminCredentialConfigurationInvalid: Networking client is experiencing an unauthorized exception.
2019-02-08 15:56:39.070 19147 ERROR nova.api.openstack.wsgi Traceback (most recent call last):
2019-02-08 15:56:39.070 19147 ERROR nova.api.openstack.wsgi   File "/usr/lib/python2.7/site-packages/nova/api/openstack/wsgi.py", line 801, in wrapped
2019-02-08 15:56:39.070 19147 ERROR nova.api.openstack.wsgi     return f(*args, **kwargs)
2019-02-08 15:56:39.070 19147 ERROR nova.api.openstack.wsgi   File "/usr/lib/python2.7/site-packages/nova/api/validation/__init__.py", line 110, in wrapper
2019-02-08 15:56:39.070 19147 ERROR nova.api.openstack.wsgi     return func(*args, **kwargs)
2019-02-08 15:56:39.070 19147 ERROR nova.api.openstack.wsgi   File "/usr/lib/python2.7/site-packages/nova/api/validation/__init__.py", line 110, in wrapper
2019-02-08 15:56:39.070 19147 ERROR nova.api.openstack.wsgi     return func(*args, **kwargs)
2019-02-08 15:56:39.070 19147 ERROR nova.api.openstack.wsgi   File "/usr/lib/python2.7/site-packages/nova/api/validation/__init__.py", line 110, in wrapper
2019-02-08 15:56:39.070 19147 ERROR nova.api.openstack.wsgi     return func(*args, **kwargs)
2019-02-08 15:56:39.070 19147 ERROR nova.api.openstack.wsgi   File "/usr/lib/python2.7/site-packages/nova/api/validation/__init__.py", line 110, in wrapper
2019-02-08 15:56:39.070 19147 ERROR nova.api.openstack.wsgi     return func(*args, **kwargs)
2019-02-08 15:56:39.070 19147 ERROR nova.api.openstack.wsgi   File "/usr/lib/python2.7/site-packages/nova/api/validation/__init__.py", line 110, in wrapper
2019-02-08 15:56:39.070 19147 ERROR nova.api.openstack.wsgi     return func(*args, **kwargs)
2019-02-08 15:56:39.070 19147 ERROR nova.api.openstack.wsgi   File "/usr/lib/python2.7/site-packages/nova/api/validation/__init__.py", line 110, in wrapper
2019-02-08 15:56:39.070 19147 ERROR nova.api.openstack.wsgi     return func(*args, **kwargs)
2019-02-08 15:56:39.070 19147 ERROR ...
(more)
edit retag flag offensive close merge delete

Comments

The message says

please verify Neutron admin credential located in nova.conf

I would follow this advice.

Bernd Bausch gravatar imageBernd Bausch ( 2019-02-08 06:45:06 -0500 )edit

Dear Bernd Baush. Thankyu for your response.

Yes I check that before I make this post. I add the [neutron] part of my nova.conf to the question..

all I found that looks like credentials is 'username' and 'password'. Is that the one that I have to verify? If so, it's there from the start.

binooetomo gravatar imagebinooetomo ( 2019-02-08 18:58:58 -0500 )edit

An example for correct configuration can be found in the installation guide.

You did not update your question, by the way.

Bernd Bausch gravatar imageBernd Bausch ( 2019-02-08 19:51:33 -0500 )edit

Dear Bernd Bausch. Hopefully know edited.

Yes, I'm trying to understand the installation guide you refered.

But no luck yet

binooetomo gravatar imagebinooetomo ( 2019-02-08 23:19:58 -0500 )edit

Solved. add project_domain_name Create server from cli without defining security-group.

My fault here.

Really appreciate your help

binooetomo gravatar imagebinooetomo ( 2019-02-08 23:50:16 -0500 )edit