Ask Your Question
0

SSH to instance not working "No route to host"

asked 2019-02-07 16:18:18 -0600

Riccardo M. gravatar image

updated 2019-02-22 17:31:11 -0600

I have setup my cloud using this official guide about [OpenStack Charms Deployment Guide].(https://docs.openstack.org/project-deploy-guide/charm-deployment-guide/latest/install-maas.html)

My lab is the following:

my lab:

  • 1 IBM System 3540 M4 Maas (500GB HDD - 8GB RAM - 1 Nic)
  • 1 IBM System 3540 M4 Juju (500GB HDD - 8GB RAM -1 Nic)
  • 4 IBM System 3540 M4 Openstack (500GBx2 HDD - 16GB RAM - 2 Nic)
  • 1 Palo Alto Network Firewall

Public Network 10.20.81.0/24 Private Network 10.0.0.0/24

  • Maas: 10.20.81.1
  • Juju: 10.20.81.2
  • Openstack 10.20.81.21-24
  • Gateway 10.20.81.254
  • Instance: 10.0.0.51 - 10.20.81.215(floating)

I can not access via SSH to new instance from my PC or Maas server

$: ssh -i ~/.ssh/id_rsa.pub 10.20.81.215
ssh: connect to host 10.20.81.215 port 22: No route to host

$: ping 10.20.81.215
PING 10.20.81.215 (10.20.81.215) 56(84) bytes of data.
From 10.20.81.1 icmp_seq=1 Destination Host Unreachable

While I reach the lxd units and the rest of nodes.

$: ping 10.20.81.21 
PING 10.20.81.21 (10.20.81.21) 56(84) bytes of data. 
64 bytes from 10.20.81.21: icmp_seq=1 ttl=64 time=0.213 ms

Maas route:

$: ip route
default via 10.20.81.254 dev enp2s0 proto static 
10.20.81.0/24 dev enp2s0 proto kernel scope link src 10.20.81.1

Juju Controller:

ubuntu@juju-controller:~$ ip route
default via 10.20.81.254 dev enp8s0 proto static 
10.20.81.0/24 dev enp8s0 proto kernel scope link src 10.20.81.2

Compute Nodes:

ubuntu@os-compute01:~$ ip route
default via 10.20.81.254 dev br-eno2 proto static 
10.20.81.0/24 dev br-eno2 proto kernel scope link src 10.20.81.21 
10.38.53.0/24 dev lxdbr0 proto kernel scope link src 10.38.53.1

ubuntu@os-compute02:~$ ip route
default via 10.20.81.254 dev br-eno2 proto static 
10.20.81.0/24 dev br-eno2 proto kernel scope link src 10.20.81.22 
10.104.230.0/24 dev lxdbr0 proto kernel scope link src 10.104.230.1 

ubuntu@os-compute03:~$ ip route
default via 10.20.81.254 dev br-eno2 proto static 
10.20.81.0/24 dev br-eno2 proto kernel scope link src 10.20.81.23 
10.126.34.0/24 dev lxdbr0 proto kernel scope link src 10.126.34.1 

ubuntu@os-compute04:~$ ip route
default via 10.20.81.254 dev br-eno2 proto static 
10.20.81.0/24 dev br-eno2 proto kernel scope link src 10.20.81.24 
10.72.47.0/24 dev lxdbr0 proto kernel scope link src 10.72.47.1

Router:

$:openstack router show u1804Ro
Password: 
+-------------------------+------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+
| Field                   | Value                                                                                                                                                                                    |
+-------------------------+------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------+
| admin_state_up          | UP                                                                                                                                                                                       |
| availability_zone_hints |                                                                                                                                                                                          |
| availability_zones      | nova                                                                                                                                                                                     |
| created_at              | 2019-02-22T20:37:46Z                                                                                                                                                                     |
| description             |                                                                                                                                                                                          |
| distributed             | False                                                                                                                                                                                    |
| external_gateway_info   | {"network_id": "25641239-aec8-4666-8e8d-95ec20c0b88d", "enable_snat": true ...
(more)
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2019-02-10 23:09:23 -0600

TijoV gravatar image

updated 2019-02-10 23:14:28 -0600

I hope you can ssh to MAAS machine, if you are, then from MAAS machine Try juju status and then

juju ssh <host_ip>
edit flag offensive delete link more

Comments

that works well...the issue is on the instance created on Openstack. The IP address 10.20.81.50, showed above, is the floating address assigned of Openstack to Vm, and if a try to make a ssh to that obtain tha error. I think the issue is on virtual router. Any idea?

Riccardo M. gravatar imageRiccardo M. ( 2019-02-11 03:53:38 -0600 )edit
1

Can you verify that the router is configured with the proper upstream gateway to access the internet? If you can't ping the router, I'm guessing it isn't accessible from your network.

reynoni gravatar imagereynoni ( 2019-02-14 11:15:40 -0600 )edit

from nodes, from lxd vm, maas and juju server the ping reach the gw and internet without issue. Each part has configured as gw the same IP (10.20.81.254). I've also rebuild the empire lab using conjure-up but the issue is the same and don't know if I wrong something on Openstack or Maas

Riccardo M. gravatar imageRiccardo M. ( 2019-02-15 12:20:16 -0600 )edit

Pretty sure it's a neutron misconfiguration in openstack. I haven't had any success with conjure-up, but juju deploy openstack-base seems pretty reliable if you can manage that.

reynoni gravatar imagereynoni ( 2019-02-19 13:51:35 -0600 )edit

I'm rebuilding that as you said me and upgrade the post, but I've the same issue

Riccardo M. gravatar imageRiccardo M. ( 2019-02-20 10:30:24 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-02-07 16:18:18 -0600

Seen: 76 times

Last updated: 20 hours ago