neutron-server returns 'Error:503' after update to queens

asked 2019-02-05 05:07:16 -0500

Luke404 gravatar image

Hi folks,

I updated my openstack environment from newton to queens. Because i didn't found a best practice solution for an upgrade progress, i used apt to upgrade the packages to queens. I encountered serveral errors from keystone, glance and nova and could all fix them with some changes in the database and the config files (specialy i changed the auth. method from v2 to v3). But unfortunately i didn't found out the problem with my neutron configuration. Everytime when i try to list my networks i receive the following error:

******@ctrl:~$ openstack network list
HttpException: 503: Server Error for url: http://ctrl:9696/v2.0/networks, Service Unavailable

/var/log/neutron-server.log

2019-02-05 09:37:09.263 21087 WARNING keystonemiddleware.auth_token [-] Identity response: {"error": {"message": "The request you have made requires authentication.", "code": 401, "title": "Unauthorized"}}: Unauthorized: The request you have made requires authentication. (HTTP 401) (Request-ID: req-a7c96551-ca90-48e8-af95-297acc82bd23)
    2019-02-05 09:37:09.287 21087 WARNING keystonemiddleware.auth_token [-] Identity response: {"error": {"message": "The request you have made requires authentication.", "code": 401, "title": "Unauthorized"}}: Unauthorized: The request you have made requires authentication. (HTTP 401) (Request-ID: req-beed4c2e-1c65-4adf-bb3c-17b6b7170e64)
    2019-02-05 09:37:09.288 21087 CRITICAL keystonemiddleware.auth_token [-] Unable to validate token: Identity server rejected authorization necessary to fetch token data: ServiceError: Identity server rejected authorization necessary to fetch token data
    2019-02-05 09:37:09.289 21087 INFO neutron.wsgi [-] 192.168.0.2 "GET /v2.0/ports?tenant_id=885ea3ee676b41c6a2ef1d15b76e1ff0&device_id=286b1b13-cba6-45f7-8934-421f675778d4 HTTP/1.1" status: 503  len: 386 time: 0.0506890

/var/log/apache2/keystone_access.log

192.168.0.1 - - [05/Feb/2019:09:37:09 +0000] "POST /v3/auth/tokens HTTP/1.1" 401 482 "-"
"neutron/12.0.5 keystonemiddleware.auth_token/4.21.0 keystoneauth1/3.4.0 python-requests/
2.18.4 CPython/2.7.12"
192.168.0.1 - - [05/Feb/2019:09:37:09 +0000] "POST /v3/auth/tokens HTTP/1.1" 401 481 "-"
"neutron/12.0.5 keystonemiddleware.auth_token/4.21.0 keystoneauth1/3.4.0 python-requests/
2.18.4 CPython/2.7.12"
192.168.0.1 - - [05/Feb/2019:09:37:11 +0000] "GET /v3/auth/tokens HTTP/1.1" 200 4982 "-"
"python-keystoneclient"
192.168.0.1 - - [05/Feb/2019:09:37:20 +0000] "POST /v3/auth/tokens HTTP/1.1" 401 482 "-"
"neutron/12.0.5 keystonemiddleware.auth_token/4.21.0 keystoneauth1/3.4.0 python-requests/
2.18.4 CPython/2.7.12"
192.168.0.1 - - [05/Feb/2019:09:37:20 +0000] "POST /v3/auth/tokens HTTP/1.1" 401 481 "-"
"neutron/12.0.5 keystonemiddleware.auth_token/4.21.0 keystoneauth1/3.4.0 python-requests/
2.18.4 CPython/2.7.12"

I check the configured password in /etc/neutron and /etc/nova for the [keystone_auth] several times and it's correct!

My configurations files for neutron: /etc/neutron/neutron.conf

  [DEFAULT]
# ...
core_plugin = ml2
service_plugins = router
allow_overlapping_ips = true
transport_url = rabbit://openstack:<passwordRemoved>@ctrl
auth_strategy = keystone
notify_nova_on_port_status_changes = true
notify_nova_on_port_data_changes = true

[keystone_authtoken]
# ...
auth_uri = http://ctrl:5000
auth_url = http://ctrl:5000
memcached_servers = ctrl:11211
auth_type ...
(more)
edit retag flag offensive close merge delete