How to configure devstack with ceilometer and gnocchi to show cpu metrics?

asked 2019-02-03 21:58:51 -0500

limciana gravatar image

Hi! I configured devstack to include ceilometer and gnocchi by adding the block of code below in my local.conf file (passwords redacted). I followed https://ask.openstack.org/en/question/116895/how-to-configure-devstack-with-ceilometer-gnocchi-and-aodh-components/ (this) for configuring my local.conf file. My problem is that whenever I type gnocchi metric list to the command line, it doesn't show me any cpu metrics, only storage metrics. From my understanding, cpu metrics are default metrics for ceilometer and gnocchi, and that it should be already be included after installation. I really need to get the cpu metrics. Am I missing something in my installation? Thank you!

[[local|localrc]]
DEST=${DEST:-"/opt/stack"}
DATA_DIR=${DATA_DIR:-"${DEST}/data"}

ENABLE_SERVICES=placement-api

enable_service c-bak
enable_service swift
enable_service compute
enable_service identity
enable_service image-service

enable_plugin heat https://git.openstack.org/openstack/heat stable/rocky
enable_service h-eng h-api h-api-cfn h-api-cw

CEILOMETER_BACKEND=gnocchi
enable_plugin ceilometer https://git.openstack.org/openstack/ceilometer stable/rocky
enable_service ceilometer
enable_plugin aodh https://git.openstack.org/openstack/aodh stable/rocky
edit retag flag offensive close merge delete

Comments

Try runnning command "sudo systemctl status devstack@*" and check if all the services are active and running without any error. (especially nova services)

pm gravatar imagepm ( 2019-02-03 23:56:13 -0500 )edit

do I have to enable nova service in my local.conf file? the only services that are running are devstack@etcd.service, devstack@q-svc.service, devstack@c-sch.service

limciana gravatar imagelimciana ( 2019-02-06 00:49:31 -0500 )edit