Ask Your Question
0

Replacing /dashboard URL with / doesn't work in OpenStack Horizon?

asked 2019-01-25 12:49:48 -0500

zetret12 gravatar image

After setting up, I went to the local_settings file under the /etc/openstack-dashboard directory, and replaced all occurrences of /dashboard with just '/'. I restarted the httpd.service and memcahed. Still, I am unable to reach the OpenStack dashboard from the / URL and need to use /dashboard.

ERROR: Not Found

The requested URL /auth/login/ was not found on this server.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2019-01-25 13:42:33 -0500

zetret12 gravatar image

This was fixed by finding the dashboard configuration file under /etc/httpd/conf.d and simply adding a server alias with the public IP information. For example;

ServerAlias private_IP public_IP

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-01-25 12:49:48 -0500

Seen: 50 times

Last updated: Jan 25