why i can't add compute endpoint

asked 2019-01-21 21:28:41 -0600

erchad gravatar image

Hello

Why i can't create endpoint for compute service here is the error :

Multiple service matches found for 'compute', use an ID to be more specific.

but on endpoint list there is no compute -_-

openstack endpoint list

| 15ea143688d64a6b9b4b01f2e2f4c71a | RegionOne | cinderv2     | volumev2     | True    | internal  | http://controller:8776/v2/%(project_id)s |
| 5182fd7d956a42bfac43b35835f41489 | RegionOne | cinderv3     | volumev3     | True    | public    | http://10.10.1.10:8776/v3/%(tenant_id)s  |
| 54deb3a2819b48d788117c30c207ba49 | RegionOne | glance       | image        | True    | internal  | http://10.10.1.10:9292                   |
| 583648e7dbfa4e359ecc74616c8318fb | RegionOne | placement    | placement    | True    | internal  | http://10.10.1.10:8778                   |
| 5cc7e419d7a84f528db6566da711873b | RegionOne | cinderv2     | volumev2     | True    | public    | http://controller:8776/v2/%(project_id)s |
| 695057f4d55243f9a78873c0ef8d4f27 | RegionOne | keystone     | identity     | True    | public    | http://10.10.1.10:5000/v3/               |
| 6d190753af504870833513a505fa1168 | RegionOne | placement    | placement    | True    | admin     | http://10.10.1.10:8778                   |
| 7009ca1c3b964e4ca9bc4e8baf732257 | RegionOne | glance       | image        | True    | admin     | http://10.10.1.10:9292                   |
| 9f1925d200ca4b979296c7f1f07813b2 | RegionOne | cinderv3     | volumev3     | True    | internal  | http://10.10.1.10:8776/v3/%(tenant_id)s  |
| acad977d3c1f4398b236d18842ae96a2 | RegionOne | cinderv2     | volumev2     | True    | admin     | http://controller:8776/v2/%(project_id)s |
| b6fe28b7ebd54038889082fa06f275c7 | RegionOne | keystone     | identity     | True    | admin     | http://10.10.1.10:5000/v3/               |
| b76d263ffcdd443a891a1a802fa489fa | RegionOne | placement    | placement    | True    | public    | http://10.10.1.10:8778                   |
| b8463d9defb546eea1b00c52bffc9cf4 | RegionOne | cinderv3     | volumev3     | True    | admin     | http://10.10.1.10:8776/v3/%(tenant_id)s  |
| c18a39dc1b014fd8a68294a68f60178a | RegionOne | keystone     | identity     | True    | internal  | http://10.10.1.10:5000/v3/               |
| d47bd1f9b52c42719ab14f68a2160027 | RegionOne | glance       | image        | True    | public    | http://10.10.1.10:9292                   |
edit retag flag offensive close merge delete

Comments

What is the precise command you use to create the endpoint?

Bernd Bausch gravatar imageBernd Bausch ( 2019-01-21 23:24:30 -0600 )edit

here is the command

openstack endpoint create --region RegionOne compute public http://$controller:8774/v2.1/%\(tenant_id\)s
erchad gravatar imageerchad ( 2019-01-21 23:43:13 -0600 )edit

That looks correct. Now, could it be that you have more than one service named compute?

openstack service list
Bernd Bausch gravatar imageBernd Bausch ( 2019-01-22 01:58:00 -0600 )edit

yes, there are 2 compute service hhmmm, should i delete once?

erchad gravatar imageerchad ( 2019-01-22 02:12:17 -0600 )edit

waw it solved my problem, thanks, i just need to delete the one of them wkwkw thank you

erchad gravatar imageerchad ( 2019-01-22 02:14:11 -0600 )edit