Ask Your Question
0

cannot ssh to vm deployed on provider network

asked 2019-01-18 06:46:45 -0500

chakravarthy gravatar image

I could ssh to any VM deployed on private(selfservice) network but I ccouldn't ssh to a VM deployed on public(provider) network.

Not sure what logs I should be looking into to debug this issue. Any suggestions to debug or fix this issue would be of great help. I will share if any logs are required.

Thanks, Chakravarthy

edit retag flag offensive close merge delete

Comments

Check the instances console log or access the interactive console to see if DHCP was successful.

Are you sure there is a DHCP server on the public network? On my devstack server DHCP is disabled on public.

Bernd Bausch gravatar imageBernd Bausch ( 2019-01-18 07:17:09 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2019-03-13 06:57:45 -0500

chakravarthy gravatar image

updated 2019-03-13 07:06:42 -0500

I could resolve this issue by adding br-ex(br-provider) to my compute node, all thanks to @Bernd Bausch

Below are the changes I made to fix this issue.

  1. Create the OVS provider bridge:

    $ ovs-vsctl add-br br-provider

  2. In the /etc/neutron/plugins/ml2/openvswitch_agent.ini file, configure the layer-2 agent.

    [ovs]

    bridge_mappings = provider:br-provider

    local_ip = OVERLAY_INTERFACE_IP_ADDRESS

    [agent]

    tunnel_types = vxlan

    l2_population = True

    [securitygroup]

    firewall_driver = iptables_hybrid

    Note: Replace OVERLAY_INTERFACE_IP_ADDRESS with the IP address of the interface that handles VXLAN overlays for provider networks.

Reference link: https://docs.openstack.org/ocata/networking-guide/deploy-ovs-selfservice.html (https://docs.openstack.org/ocata/netw...)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-01-18 06:46:45 -0500

Seen: 80 times

Last updated: Mar 13