Ask Your Question
0

Gnocchi measures result showing empty

asked 2019-01-18 04:25:20 -0500

hariprasath M gravatar image

updated 2019-01-18 04:25:58 -0500

Hi All,

I have configured gnocchi with ceilometer in Queens on Ubuntu 16.04. After the configuration I am able to get resources and metrics but couldn't get any measures for any resources.

Getting (gnocchi.cli.metricd: 0 measurements bundles across 0 metrics wait to be processed) in gnocchi-metricd.log

Please help on this, if you have faced this earlier.

Regards, Hariprasath M

edit retag flag offensive close merge delete

Comments

How are the publishers configured in pipeline.yaml?

Any errors reported in ceilometer or gnocchi log files?

How do you try to retrieve the measures? Please share the exact command.

Bernd Bausch gravatar imageBernd Bausch ( 2019-01-18 22:25:28 -0500 )edit

Hi Bernd,

Please find my pipeline configuration, where I have update gnocchi url as - gnocchi://?filter_project=service&archive_policy=low under publisher.

retrieve the measures - gnocchi measures show <metric id="">

hariprasath M gravatar imagehariprasath M ( 2019-01-21 23:43:16 -0500 )edit

And there are no error in logs except this notification in gnocchi-metric.log

2019-01-22 10:57:39,975 [28035] INFO gnocchi.cli.metricd: Joined coordination group: gnocchi-processing 2019-01-22 10:57:39,975 [28035] INFO gnocchi.cli.metricd: Incoming driver does not support notification

hariprasath M gravatar imagehariprasath M ( 2019-01-21 23:44:02 -0500 )edit

Could it be that there are no measures for this metric? Have you tried other metrics?

Bernd Bausch gravatar imageBernd Bausch ( 2019-01-22 05:43:41 -0500 )edit

Yes tried but no measures for any of the metrics.

hariprasath M gravatar imagehariprasath M ( 2019-01-22 06:04:57 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2019-01-30 04:52:05 -0500

hariprasath M gravatar image

updated 2019-01-30 05:04:31 -0500

This gnocchi gave an output, when we pulled once manually using metric name and also ensure that "/var/lib/gnocchi" directory has enough permission to write data.

gnocchi measures add -r "resource id" -m "time stamp" "metric name"

e.g:

gnocchi measures add -r 05063931-3377-41f6-a7c2-7f9b7a6c729f -m 2019-01-28T08:00:39@300 image.download

This is helped!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-01-18 04:25:20 -0500

Seen: 409 times

Last updated: Jan 30