Ask Your Question
0

i got Internal Server Error on Horizon

asked 2019-01-16 09:27:20 -0500

erchad gravatar image

updated 2019-01-16 10:09:15 -0500

here is the error.log :

[Wed Jan 16 14:48:17.201954 2019] [wsgi:error] [pid 10244:tid 139778535470848] [remote 10.10.28.88:15816] mod_wsgi (pid=10244): Target WSGI script '/usr/share/openstac$
[Wed Jan 16 14:48:17.202803 2019] [wsgi:error] [pid 10244:tid 139778535470848] [remote 10.10.28.88:15816] mod_wsgi (pid=10244): Exception occurred processing WSGI scri$
[Wed Jan 16 14:48:17.202967 2019] [wsgi:error] [pid 10244:tid 139778535470848] [remote 10.10.28.88:15816] Traceback (most recent call last):
[Wed Jan 16 14:48:17.203056 2019] [wsgi:error] [pid 10244:tid 139778535470848] [remote 10.10.28.88:15816]   File "/usr/share/openstack-dashboard/openstack_dashboard/ws$
[Wed Jan 16 14:48:17.203155 2019] [wsgi:error] [pid 10244:tid 139778535470848] [remote 10.10.28.88:15816]     application = get_wsgi_application()
[Wed Jan 16 14:48:17.203230 2019] [wsgi:error] [pid 10244:tid 139778535470848] [remote 10.10.28.88:15816]   File "/usr/lib/python2.7/dist-packages/django/core/wsgi.py"$
[Wed Jan 16 14:48:17.203310 2019] [wsgi:error] [pid 10244:tid 139778535470848] [remote 10.10.28.88:15816]     django.setup(set_prefix=False)
[Wed Jan 16 14:48:17.203398 2019] [wsgi:error] [pid 10244:tid 139778535470848] [remote 10.10.28.88:15816]   File "/usr/lib/python2.7/dist-packages/django/__init__.py",$
[Wed Jan 16 14:48:17.203477 2019] [wsgi:error] [pid 10244:tid 139778535470848] [remote 10.10.28.88:15816]     configure_logging(settings.LOGGING_CONFIG, settings.LOGGI$
[Wed Jan 16 14:48:17.203549 2019] [wsgi:error] [pid 10244:tid 139778535470848] [remote 10.10.28.88:15816]   File "/usr/lib/python2.7/dist-packages/django/conf/__init__$
[Wed Jan 16 14:48:17.203627 2019] [wsgi:error] [pid 10244:tid 139778535470848] [remote 10.10.28.88:15816]     self._setup(name)
[Wed Jan 16 14:48:17.203670 2019] [wsgi:error] [pid 10244:tid 139778535470848] [remote 10.10.28.88:15816]   File "/usr/lib/python2.7/dist-packages/django/conf/__init__$
[Wed Jan 16 14:48:17.203715 2019] [wsgi:error] [pid 10244:tid 139778535470848] [remote 10.10.28.88:15816]     self._wrapped = Settings(settings_module)
[Wed Jan 16 14:48:17.203753 2019] [wsgi:error] [pid 10244:tid 139778535470848] [remote 10.10.28.88:15816]   File "/usr/lib/python2.7/dist-packages/django/conf/__init__$
[Wed Jan 16 14:48:17.203796 2019] [wsgi:error] [pid 10244:tid 139778535470848] [remote 10.10.28.88:15816]     mod = importlib.import_module(self.SETTINGS_MODULE)
[Wed Jan 16 14:48:17.203834 2019] [wsgi:error] [pid 10244:tid 139778535470848] [remote 10.10.28.88:15816]   File "/usr/lib/python2.7/importlib/__init__.py", line 37, i$
[Wed Jan 16 14:48:17.206565 2019] [wsgi:error] [pid 10244:tid 139778535470848] [remote 10.10.28.88:15816]     __import__(name)
[Wed Jan 16 14:48:17.206920 2019] [wsgi:error] [pid 10244:tid 139778535470848] [remote 10.10.28.88:15816]   File "/usr/lib/python2.7/dist-packages/openstack_dashboard/$
[Wed Jan 16 14:48:17.207041 2019] [wsgi:error] [pid 10244:tid 139778535470848] [remote 10.10.28 ...
(more)
edit retag flag offensive close merge delete

Comments

My guess is that the syntax error is provoked by the previous lines. Show some context.

And format your code so that it becomes readable. You have a button labeled "101010" for this purpose.

Bernd Bausch gravatar imageBernd Bausch ( 2019-01-16 10:10:41 -0500 )edit

here is the script :

ALLOWED_HOSTS = ["controller","localhost"]
OPENSTACK_API_VERSIONS = {
#    "data-processing": 1.1,
    "identity": 3,
    "image": 2,
    "volume": 2,
    "compute": 2,
#}

OPENSTACK_KEYSTONE_MULTIDOMAIN_SUPPORT = True
OPENSTACK_KEYSTONE_DEFAULT_DOMAIN = 'Default'
erchad gravatar imageerchad ( 2019-01-16 20:07:51 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2019-01-16 21:17:10 -0500

updated 2019-01-16 22:47:01 -0500

The closing parenthesis is commented out.

Up to True, the file is syntactically correct. Since the word OPENSTACK_KEYSTONE_DEFAULT_DOMAIN is not separated from True with a comma, the syntax error is generated at the OPENSTACK_KEYSTONE_DEFAULT_DOMAIN line. Of course, the real error is the lack of a closing parenthesis.

edit flag offensive delete link more

Comments

so, i need to erase the comma on True ?

erchad gravatar imageerchad ( 2019-01-16 23:25:59 -0500 )edit

There is no comma on True. But an open parenthesis without a closing one will cause a syntax error.

Bernd Bausch gravatar imageBernd Bausch ( 2019-01-17 01:09:40 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-01-16 09:27:20 -0500

Seen: 99 times

Last updated: Jan 16