ssh an openstack instance is too slow

asked 2019-01-16 05:13:44 -0600

najeh gravatar image

when i tried to access an openstack instance using " ssh -i mykey.pem ubuntu@192.168.x.x" is too slow takes hours to realize the demand.

Where is the problem and how can i solve it ?

edit retag flag offensive close merge delete

Comments

1

Possible cause: A failing DNS lookup. There is an option in sshd_config that disables the DNS lookup, or you can configure DNS.

In my experience, Fedora is slow, Ubuntu is much better. I have not explored why.

Bernd Bausch gravatar imageBernd Bausch ( 2019-01-16 05:52:31 -0600 )edit

i'm already working with ubuntu and in my sshd_config the DNS lookup is disabled GSSAPIAuthentication=no and also UseDNS no

but i still have the problem.

najeh gravatar imagenajeh ( 2019-01-16 07:16:10 -0600 )edit
1

Have you debugged (ssh -v user@target) at which point the ssh connection stops? You can use '-v' multiple times to increase verbosity: ssh -vvv user@target

eblock gravatar imageeblock ( 2019-01-16 08:52:54 -0600 )edit