Ask Your Question
0

How can I specify how to specify Open vSwitch version for devstack version for devstack?

asked 2019-01-09 23:32:34 -0500

hoangphuoc gravatar image

I want to use Open vSwitch version 2.9.2 for my Devstack environment. So how can I specify it on local.conf file. I tried to use OVS_BRANCH but it won't work.

Thank for your help.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2019-01-10 03:15:41 -0500

updated 2019-01-10 03:16:15 -0500

Looking at Neutron's devstack code, it looks like you have to set Q_BUILD_OVS_FROM_GIT to True.

edit flag offensive delete link more

Comments

Thank Bernd,

But when I add Q_BUILD_OVS_FROM_GIT parameter, my ovs version is still 2.9.0.

hoangphuoc gravatar imagehoangphuoc ( 2019-01-14 02:32:41 -0500 )edit

Do you set both Q_BUILD_OVS_FROM_GIT and OVS_BRANCH? If so, I don't understand what happens. It should not be too hard to add debugging output (echo's and set -x) to the plugin.sh.

Bernd Bausch gravatar imageBernd Bausch ( 2019-01-14 04:07:13 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-01-09 23:32:34 -0500

Seen: 28 times

Last updated: Jan 14