Ask Your Question
1

Openstack conjure-up networking

asked 2019-01-08 07:47:27 -0600

Fabry gravatar image

I succeeded to install an Openstack cluster on 5 servers using MAAS and conjure-up (using this https://www.ubuntu.com/openstack/install#cluster-deployment (tutorial) ).
I also deployed a new ubuntu Instance using the Horizon GUI.
Now I'm stuck to configure the network.
I deployed the instance with one private IP and one floating IP.
I cannot ping the instance from the openstack-controller (I tried to ping both IPs, private and floating).

This is my current network topology: https://www.dropbox.com/s/gp8l07k1gy1bsiw/I3bd0.png?dl=0 (Image)

I created the Public network selecting as "Provider Network Type": "Flat" (I tried also "VLAN") and as "Physical Network": "physnet1" (not sure about this configuration, I used the default conjure-up settings. Do I have to use a different provider?)

This is my default security group: https://www.dropbox.com/s/4ig9mejrqk5cohn/fDPQV.png?dl=0 (Image)

This is my instance: https://www.dropbox.com/s/kwuaoyhxacozbll/P3A2W.png?dl=0 (Image)

Also all physical servers are connected to the same network switch (isolated) as specified in the conjure-up tutorial: "Connect the both NICs of the servers to the same network switch.".

What can I check to find the problem? Are my configuration right?

thank you

edit retag flag offensive close merge delete

Comments

Did you have any luck with this?

Josh Fuhs gravatar imageJosh Fuhs ( 2019-09-09 20:46:12 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2019-09-12 10:52:23 -0600

Josh Fuhs gravatar image

As of the time of writing, the conjure-up installation does not create a physical network that can be reached from the outside.

To fix this, change the conjure-up neutron-gateway parameter data-port to br-ex:ens8. This will bridge the OpenStack physical network physnet1 to the second interface on the neutron-gateway service host, putting your allocated floating IPs on whatever subnet is available at that port.

You can also adjust this after a conjure-up installation by running from the MAAS host:

juju run --unit neutron-gateway/0 sudo ovs-vsctl add-port br-ex ens8

However, this won't be recognized in the neutron-gateway charm settings and probably won't work long term. I'm not yet sure how to adjust and apply settings changes after deployment.

Your OpenStack public network will need to have the following parameters:

Admin State: Up
Shared: No
External Network: Yes
Provider: Network Type: flat  # Unless the second port is connected to a VLAN switch
Provider: Physical Network: physnet1

The subnet should be the same as that of the second port of the neutron-gateway service host. For a conjure-up install as described in the Canonical documentation (https://ubuntu.com/openstack/install#...), it will be the same network as the MAAS server. Disable DHCP on the OpenStack subnet, otherwise OpenStack will be fighting with MAAS.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-01-08 07:43:50 -0600

Seen: 87 times

Last updated: Sep 12 '19