Ask Your Question
0

OpenStack Magnum installation

asked 2019-01-01 10:52:38 -0500

Dragon gravatar image

Hi everyone. I'm trying to run OpenStack Magnum project on my VPS. the OpenStack works fine and Based on this guide:

https://docs.openstack.org/magnum/rocky/install/install-ubuntu.html

I tried to install magnum on my system. after all the configurations, when I try to run this command to verify the operation:

openstack coe service list

i get this result:

stack@vps1:~$ openstack coe service list
Unable to establish connection to http://[my-server-ip-address]:9511/v1/mservices: HTTPConnectionPool(host='[my-server-ip-address]', port=9511): Max retries exceeded with url: /v1/mservices (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x7f3a52bddbd0>: Failed to establish a new connection: [Errno 111] Connection refused',))

**instead of [my-server-ip-address], there is my server ip address.**

I tried to search for solving this problem, but I wasn't able to find any answers.

Can you please help me with this problem?

Thank you.

edit retag flag offensive close merge delete

Comments

1

This means that no process listens on port 9511 on your server. I guess the Magnum API process is not running or uses a different port.

If Magnum API stopped, you should find further information in its log file.

Bernd Bausch gravatar imageBernd Bausch ( 2019-01-01 17:59:52 -0500 )edit

Thanks Bernd, I tried to check the services(magnum-api & magnum-conductor) by the "service --status-all" command; I turn them up and nothing changed about the error. also, in "sudo netstat -plnt" command, there was no record related to "magnum" or "9511" port. what should I do now?

Dragon gravatar imageDragon ( 2019-01-01 21:51:26 -0500 )edit
1

systemctl status magnum-api should give you some superficial information. For more info see the log file, probably in /var/log/magnum.

Bernd Bausch gravatar imageBernd Bausch ( 2019-01-01 23:01:14 -0500 )edit

Thanks bernd, I shared my log file in the next answer, can you please check it out?

Dragon gravatar imageDragon ( 2019-01-02 14:51:51 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2019-01-02 14:50:24 -0500

Dragon gravatar image

Thank you Bernd. in the log file, this is a section that is repeated thousands of times, over and over again.

2019-01-02 20:04:53.132 3619 INFO magnum.api.app [-] Full WSGI config used: /etc/magnum/api-paste.ini
2019-01-02 20:04:53.300 3619 WARNING keystonemiddleware._common.config [-] The option "__file__" in conf is not known to auth_token
2019-01-02 20:04:53.301 3619 WARNING keystonemiddleware._common.config [-] The option "here" in conf is not known to auth_token
2019-01-02 20:04:53.301 3619 WARNING keystonemiddleware.auth_token [-] AuthToken middleware is set with keystone_authtoken.service_token_roles_required set to False. This is backwards compatible but deprecated behaviour. Please set this to True.
2019-01-02 20:04:53.304 3619 CRITICAL magnum [-] Unhandled error: MissingRequiredOptions: Auth plugin requires parameters which were not given: auth_url
2019-01-02 20:04:53.304 3619 ERROR magnum Traceback (most recent call last):
2019-01-02 20:04:53.304 3619 ERROR magnum   File "/usr/bin/magnum-api", line 10, in <module>
2019-01-02 20:04:53.304 3619 ERROR magnum     sys.exit(main())
2019-01-02 20:04:53.304 3619 ERROR magnum   File "/usr/lib/python2.7/dist-packages/magnum/cmd/api.py", line 64, in main
2019-01-02 20:04:53.304 3619 ERROR magnum     app = api_app.load_app()
2019-01-02 20:04:53.304 3619 ERROR magnum   File "/usr/lib/python2.7/dist-packages/magnum/api/app.py", line 63, in load_app
2019-01-02 20:04:53.304 3619 ERROR magnum     return deploy.loadapp("config:" + cfg_file)
2019-01-02 20:04:53.304 3619 ERROR magnum   File "/usr/local/lib/python2.7/dist-packages/paste/deploy/loadwsgi.py", line 253, in loadapp
2019-01-02 20:04:53.304 3619 ERROR magnum     return loadobj(APP, uri, name=name, **kw)
2019-01-02 20:04:53.304 3619 ERROR magnum   File "/usr/local/lib/python2.7/dist-packages/paste/deploy/loadwsgi.py", line 278, in loadobj
2019-01-02 20:04:53.304 3619 ERROR magnum     return context.create()
2019-01-02 20:04:53.304 3619 ERROR magnum   File "/usr/local/lib/python2.7/dist-packages/paste/deploy/loadwsgi.py", line 715, in create
2019-01-02 20:04:53.304 3619 ERROR magnum     return self.object_type.invoke(self)
2019-01-02 20:04:53.304 3619 ERROR magnum   File "/usr/local/lib/python2.7/dist-packages/paste/deploy/loadwsgi.py", line 213, in invoke
2019-01-02 20:04:53.304 3619 ERROR magnum     app = filter(app)
2019-01-02 20:04:53.304 3619 ERROR magnum   File "/usr/lib/python2.7/dist-packages/magnum/api/middleware/auth_token.py", line 68, in _factory
2019-01-02 20:04:53.304 3619 ERROR magnum     return cls(app, global_config, public_api_routes=public_api_routes)
2019-01-02 20:04:53.304 3619 ERROR magnum   File "/usr/lib/python2.7/dist-packages/magnum/api/middleware/auth_token.py", line 46, in __init__
2019-01-02 20:04:53.304 3619 ERROR magnum     super(AuthTokenMiddleware, self).__init__(app, conf)
2019-01-02 20:04:53.304 3619 ERROR magnum   File "/usr/local/lib/python2.7/dist-packages/keystonemiddleware/auth_token/__init__.py", line 576, in __init__
2019-01-02 20:04:53.304 3619 ERROR magnum     self._auth = self._create_auth_plugin()
2019-01-02 20:04:53.304 3619 ERROR magnum   File "/usr/local ...
(more)
edit flag offensive delete link more

Comments

1

This looks obvious:

Auth plugin requires parameters which were not given: auth_url

You seem to have forgotten to set auth_url in the keystone_authtoken section.

Bernd Bausch gravatar imageBernd Bausch ( 2019-01-02 17:28:46 -0500 )edit

but I've provided the "auth_url" in the /etc/magnum/magnum.conf before, and there is nothing wrong with it. although I replaced my server's IP address with the word "controller". I'll share the "keystone_authtoken" section in the next comment. thanks for your help bernd, I',m very greatful

Dragon gravatar imageDragon ( 2019-01-03 03:58:04 -0500 )edit

[keystone_auth]:

auth_type = password

auth_url = http://[my-servers-ip-address]:35357

project_name = service

project_domain_id = default

username = magnum

user_domain_id = default

password = [my-password]

Dragon gravatar imageDragon ( 2019-01-03 04:06:38 -0500 )edit

[keystone_authtoken]:

auth_uri = http://[my-servers-ip-address]:5000/v3

auth_version = v3

Dragon gravatar imageDragon ( 2019-01-03 04:57:05 -0500 )edit
1

I think [keystone_auth] is incorrect. All the Keystone parameters should be under [keystone_authtoken].

Also, I am not sure if the documentation is correct. Does Keystone run behind port 35357?

Bernd Bausch gravatar imageBernd Bausch ( 2019-01-03 05:03:25 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2019-01-01 10:52:38 -0500

Seen: 155 times

Last updated: Jan 02