puppet openstack

asked 2018-12-28 12:05:14 -0600

novainfinite gravatar image

updated 2018-12-28 12:18:26 -0600

I want to install openstack puppet I receive this error

 Puppet failed to install repositories.                                       |

what should i do?

WARN     -> The use of the PUPPETFILE and PUPPETFILE_DIR environment variables is deprecated.
+ cp -a /home/ubuntu/puppet-openstack-integration /etc/puppetlabs/code/modules/openstack_integration
+ print_header 'Module List'
++ grep xtrace
++ set
+ '[' -n 'SHELLOPTS=braceexpand:hashall:interactive-comments:xtrace
    if [ -n "$(set | grep xtrace)" ]; then
        local enable_xtrace='\''yes'\'';
    if [ -n "${enable_xtrace}" ]; then' ']'
+ set +x
--------------------------------------------------------------------------------
| Module List                                                                  |
--------------------------------------------------------------------------------
+ puppet module list
Warning: Module 'puppetlabs-stdlib' (v5.1.0) fails to meet some dependencies:
  'puppetlabs-apache' (v3.1.0) requires 'puppetlabs-stdlib' (>= 4.13.1 < 5.0.0)
  'puppetlabs-apt' (v2.4.0) requires 'puppetlabs-stdlib' (>= 4.13.0 < 5.0.0)
  'puppetlabs-concat' (v2.2.1) requires 'puppetlabs-stdlib' (>= 4.2.0 < 5.0.0)
  'puppet-corosync' (v5.0.0) requires 'puppetlabs-stdlib' (v4.x)
  'puppetlabs-rsync' (v1.1.0) requires 'puppetlabs-stdlib' (>=4.2.0 <5.0.0)
Warning: Module 'puppetlabs-xinetd' (v3.1.0) fails to meet some dependencies:
  'openstack-ironic' (v14.1.0) requires 'puppetlabs-xinetd' (>=1.5.0 <2.0.0)
  'openstack-swift' (v14.1.0) requires 'puppetlabs-xinetd' (>=1.0.1 <2.0.1)
Warning: Module 'saz-memcached' (v3.3.0) fails to meet some dependencies:
  'openstack-horizon' (v14.1.0) requires 'saz-memcached' (>=2.0.2 <3.0.0)
  'openstack-swift' (v14.1.0) requires 'saz-memcached' (>=2.0.2 <3.0.0)
Warning: Missing dependency 'camptocamp-systemd':
  'puppet-rabbitmq' (v8.4.0) requires 'camptocamp-systemd' (>= 2.1.0 < 3.0.0)
Warning: Missing dependency 'deric-storm':
  'openstack-monasca' (v3.1.0) requires 'deric-storm' (>=0.0.1 <1.0.0)
Warning: Missing dependency 'deric-zookeeper':
  'openstack-monasca' (v3.1.0) requires 'deric-zookeeper' (>=0.0.1 <1.0.0)
Warning: Missing dependency 'jdowning-influxdb':
  'openstack-monasca' (v3.1.0) requires 'jdowning-influxdb' (>=0.3.0 <1.0.0)
Warning: Missing dependency 'maestrodev-wget':
  'openstack-monasca' (v3.1.0) requires 'maestrodev-wget' (>=0.0.1 <2.0.0)
Warning: Missing dependency 'opentable-kafka':
  'openstack-monasca' (v3.1.0) requires 'opentable-kafka' (>=1.0.0 <2.0.0)
Warning: Missing dependency 'puppet-staging':
  'puppetlabs-mysql' (v6.2.0) requires 'puppet-staging' (>= 1.0.1 < 4.0.0)
Warning: Missing dependency 'puppetlabs-rabbitmq':
  'openstack-aodh' (v14.1.0) requires 'puppetlabs-rabbitmq' (>=8.4.0 <9.0.0)
  'openstack-barbican' (v14.1.0) requires 'puppetlabs-rabbitmq' (>=8.4.0 <9.0.0)
  'openstack-ceilometer' (v14.1.0) requires 'puppetlabs-rabbitmq' (>=8.4.0 <9.0.0)
  'openstack-cinder' (v14.1.0) requires 'puppetlabs-rabbitmq' (>=8.4.0 <9.0.0)
  'openstack-cloudkitty' (v3.1.0) requires 'puppetlabs-rabbitmq' (>=8.4.0 <9.0.0)
  'openstack-congress' (v14.1.0) requires 'puppetlabs-rabbitmq' (>=8.4.0 <9.0.0)
  'openstack-designate' (v14.1.0) requires 'puppetlabs-rabbitmq' (>=8.4.0 <9.0.0)
  'openstack-glance' (v14.1.0) requires 'puppetlabs-rabbitmq' (>=8.4.0 <9.0.0)
  'openstack-heat' (v14.1.0) requires 'puppetlabs-rabbitmq' (>=8.4.0 <9.0.0)
  'openstack-ironic' (v14.1.0) requires 'puppetlabs-rabbitmq' (>=8.4.0 <9.0.0)
  'openstack-keystone' (v14.1.0) requires 'puppetlabs-rabbitmq' (>=8.4.0 <9.0.0)
  'openstack-manila' (v14.1.0) requires 'puppetlabs-rabbitmq' (>=8.4.0 <9.0.0)
  'openstack-murano' (v14.1.0) requires 'puppetlabs-rabbitmq' (>=8.4.0 <9.0.0)
  'openstack-neutron' (v14.1.0) requires 'puppetlabs-rabbitmq' (>=8.4.0 <9.0.0)
  'openstack-nova' (v14.1.0) requires 'puppetlabs-rabbitmq ...
(more)
edit retag flag offensive close merge delete