Issue With openstack Dashboard

asked 2018-12-27 09:58:56 -0600

schap gravatar image

updated 2018-12-27 10:00:19 -0600

Hey Everyone so I recently did a yum update on our openstack controller and it messed everything up. I keep getting

> == Keystone users ==
Discovering versions from the identity service failed when creating the password plugin. Attempting to determine version from URL.
Unable to establish connection to http://10.10.1.51:5000/v2.0/tokens: HTTPConnectionPool(host='10.10.1.51', port=5000): Max retries exceeded with url: /v2.0/tokens (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x7f37c7f90890>: Failed to establish a new connection: [Errno 111] Connection refused',))
== Glance images ==
Unable to establish connection to http://10.10.1.51:5000/v2.0/tokens
== Nova managed services ==
No handlers could be found for logger "keystoneauth.identity.generic.base"
ERROR (ConnectFailure): Unable to establish connection to http://10.10.1.51:5000/v2.0/tokens: HTTPConnectionPool(host='10.10.1.51', port=5000): Max retries exceeded with url: /v2.0/tokens (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x7ff6017db7d0>: Failed to establish a new connection: [Errno 111] Connection refused',))
== Nova networks ==
#]
No handlers could be found for logger "keystoneauth.identity.generic.base"
ERROR (ConnectFailure): Unable to establish connection to http://10.10.1.51:5000/v2.0/tokens: HTTPConnectionPool(host='10.10.1.51', port=5000): Max retries exceeded with url: /v2.0/tokens (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x7f0fd0ec57d0>: Failed to establish a new connection: [Errno 111] Connection refused',))
== Nova instance flavors ==
No handlers could be found for logger "keystoneauth.identity.generic.base"
ERROR (ConnectFailure): Unable to establish connection to http://10.10.1.51:5000/v2.0/tokens: HTTPConnectionPool(host='10.10.1.51', port=5000): Max retries exceeded with url: /v2.0/tokens (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x7f65ec4387d0>: Failed to establish a new connection: [Errno 111] Connection refused',))
== Nova instances ==
No handlers could be found for logger "keystoneauth.identity.generic.base"
ERROR (ConnectFailure): Unable to establish connection to http://10.10.1.51:5000/v2.0/tokens: HTTPConnectionPool(host='10.10.1.51', port=5000): Max retries exceeded with url: /v2.0/tokens (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x7f196eeca7d0>: Failed to establish a new connection: [Errno 111] Connection refused',))
[root@os-mitaka-controller ~(keystone_matonto)]# openstack endpoint list
Discovering versions from the identity service failed when creating the password plugin. Attempting to determine version from URL.
Unable to establish connection to http://10.10.1.51:5000/v2.0/tokens: HTTPConnectionPool(host='10.10.1.51', port=5000): Max retries exceeded with url: /v2.0/tokens (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x7f197cdff710>: Failed to establish a new connection: [Errno 111] Connection refused',))

Nothing seems to be starting up properly....

edit retag flag offensive close merge delete

Comments

Keystone can’t be reached, therefore nothing else works. Find out what’s wrong with Keystone.

Your cloud uses Keystonne API v2, which has been obsolete for a while. What OpenStack release is this? Is v3 accessible?

Bernd Bausch gravatar imageBernd Bausch ( 2018-12-27 15:56:15 -0600 )edit

It is on mitaka.... Is it possible to connect the one mitaka compute node we have to a rocky setup? I am just afraid to upgrade the compute node and have everything blow up again. Luckily the controller did not host any instances.

schap gravatar imageschap ( 2018-12-27 17:13:02 -0600 )edit

Mixing Mitaka compute and Rocky controller will fail. By the way, how would you add the instances to the Rocky controller’s database?

Check the Keystone logs. Perhaps there is no big problem.

Bernd Bausch gravatar imageBernd Bausch ( 2018-12-27 17:23:14 -0600 )edit

Now I get

File "/usr/lib/python2.7/site-packages/django/apps/registry.py", line 125, in check_apps_ready
python[6228]: raise AppRegistryNotReady("Apps aren't loaded yet.")
python[6228]: django.core.exceptions.AppRegistryNotReady: Apps aren't loaded yet.
schap gravatar imageschap ( 2018-12-28 11:18:04 -0600 )edit

Is Keystone running? What is in the log?

Bernd Bausch gravatar imageBernd Bausch ( 2018-12-28 17:00:59 -0600 )edit