Ask Your Question
0

alarming time [closed]

asked 2018-12-20 12:29:45 -0500

novainfinite gravatar image

updated 2018-12-22 05:31:31 -0500

i have been crasy

aodh always is insufficient data

i use alarming in newton by mongodb

rocky use gnocchi

gnocchi is working fine and every 300 second gather data

+---------------------------+-------------+-----------------+`enter code here`

| timestamp                 | granularity |           value |

+---------------------------+-------------+-----------------+


| 2018-12-20T21:00:00+00:00 |       300.0 |  0.257340088794 |

| 2018-12-20T21:05:00+00:00 |       300.0 |  0.106682143756 |

| 2018-12-20T21:10:00+00:00 |       300.0 | 0.0933462368948 |

| 2018-12-20T21:15:00+00:00 |       300.0 | 0.0933162213157 |

| 2018-12-20T21:20:00+00:00 |       300.0 |  0.089986282791 |

| 2018-12-20T21:25:00+00:00 |       300.0 | 0.0933324983186 |

there are time in aodh.conf polling.yml pipline.yml and granularity and evaluation_periods how should i configre this time?

------+---------+ | alarm_id | type | name | state | severity | enabled | +--------------------------------------+--------------------------------------------+--------------------------------+-------------------+----------+---------+ | ee4df888-7031- | gnocchi_aggregatio | s2-cpu_alarm_high-vlfxb7o2n2qn | insufficient data | low | True |

this is my ceilometer pipline.yml


sources:

- name: meter_source

  meters:

      - "*"

  sinks:

      - meter_sink

- name: cpu_source

  meters:

      - "cpu"

  sinks:

      - cpu_sink

      - cpu_delta_sink

- name: disk_source

  meters:

      - "disk.read.bytes"

      - "disk.read.requests"

      - "disk.write.bytes"

      - "disk.write.requests"

      - "disk.device.read.bytes"

      - "disk.device.read.requests"

      - "disk.device.write.bytes"

      - "disk.device.write.requests"

  sinks:

      - disk_sink

- name: network_source

  meters:

      - "network.incoming.bytes"

      - "network.incoming.packets"

      - "network.outgoing.bytes"

      - "network.outgoing.packets"

  sinks:

      - network_sink

sinks:

- name: meter_sink

  transformers:

  publishers:

      - gnocchi://

- name: cpu_sink

  transformers:

      - name: "rate_of_change"

        parameters:

            target:

                name: "cpu_util"

                unit: "%"

                type: "gauge"

                max: 100

                scale: "100.0 / (10**9 * (resource_metadata.cpu_number or 1))"

  publishers:

      - gnocchi://

- name: cpu_delta_sink

  transformers:

      - name: "delta"

        parameters:

            target:

                name: "cpu.delta"

            growth_only: True

  publishers:

      - gnocchi://

- name: disk_sink

  transformers:

      - name: "rate_of_change"

        parameters:

            source:

                map_from:

                    name: "(disk\\.device|disk)\\.(read|write)\\.(bytes|requests)"

                    unit: "(B|request)"

            target:

                map_to:

                    name: "\\1.\\2.\\3.rate"

                    unit: "\\1/s"

                type: "gauge"

  publishers:

      - gnocchi://

- name: network_sink

  transformers:

      - name: "rate_of_change"

        parameters:

            source:

               map_from:

                   name: "network\\.(incoming|outgoing)\\.(bytes|packets)"

                   unit: "(B|packet)"

            target:

                map_to:

                    name: "network.\\1.\\2.rate"

                    unit: "\\1/s"

                type: "gauge"

  publishers:

      - gnocchi://

this is my heat template

sources: - name: meter_source meters: - "" sinks: - meter_sink - name: cpu_source meters: - "cpu" sinks: - cpu_sink - cpu_delta_sink - name: disk_source meters: - "disk.read.bytes" - "disk.read.requests" - "disk.write.bytes" - "disk.write.requests" - "disk.device.read.bytes" - "disk.device.read.requests" - "disk.device.write.bytes" - "disk.device.write.requests" sinks: - disk_sink - name: network_source meters: - "network.incoming.bytes" - "network.incoming.packets" - "network.outgoing.bytes" - "network.outgoing.packets" sinks: - network_sink sinks: - name: meter_sink transformers: publishers: - gnocchi://?filter_project=service&archive_policy=low - name: cpu_sink transformers: - name: "rate_of_change" parameters: target: name: "cpu_util" unit: "%" type: "gauge" max: 100 scale: "100.0 / (10*9 * (resource_metadata.cpu_number or 1))" publishers: - gnocchi://?filter_project=service&archive_policy=low - name: cpu_delta_sink transformers: - name: "delta" parameters: target: name: "cpu.delta" growth_only: True publishers: - gnocchi://?filter_project=service&archive_policy=low - name: disk_sink transformers: - name: "rate_of_change" parameters: source: map_from: name: "(disk\.device|disk)\.(read|write)\.(bytes|requests)" unit: "(B|request)" target: map_to: name: "\1.\2.\3.rate" unit: "\1/s" type: "gauge" publishers: - gnocchi://?filter_project=service&archive_policy=low - name: network_sink transformers: - name: "rate_of_change" parameters: source: map_from: name: "network\.(incoming|outgoing)\.(bytes|packets)" unit: "(B|packet)" target: map_to: name: "network.\1.\2.rate" unit: "\1/s" type: "gauge" publishers: - gnocchi://?filter_project=service&archive_policy=low

root@controller:/var ... (more)

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by novainfinite
close date 2018-12-21 06:28:52.308848

Comments

Please add the alarm create command to your question, and the output of gnocchi measures show for the metric(s) you use in the alarm. Also, which configuration values did you set to 600?

I have recently worked with alarms and autoscaling on a Rocky Devstack. No problems. So there is hope.

Bernd Bausch gravatar imageBernd Bausch ( 2018-12-20 15:52:50 -0500 )edit

devstack is easy and for test i use multinode

novainfinite gravatar imagenovainfinite ( 2018-12-20 16:31:14 -0500 )edit

i do not have problem in newton but in rocky it always show insufficient data

novainfinite gravatar imagenovainfinite ( 2018-12-20 16:36:28 -0500 )edit

if you want challenge yourself install it manual

novainfinite gravatar imagenovainfinite ( 2018-12-20 16:38:53 -0500 )edit

alarm list doesn’t provide enough detail. alarm create (or Heat definition in your case) and alarm show would help. Also, computer output is hard to read in proportional fonts. Use the button with the “101010” label to format it.

Bernd Bausch gravatar imageBernd Bausch ( 2018-12-20 17:12:04 -0500 )edit

1 answer

Sort by » oldest newest most voted
2

answered 2018-12-20 23:52:39 -0500

updated 2018-12-20 23:52:56 -0500

The instances in the autoscaling group are configured with metadata “metering.stack”, but the alarm queries for “server_group”. Since none of your instances have metadata “server_group”, the alarm’s query gets no result from Gnocchi, thus insufficient data.

edit flag offensive delete link more

Comments

thanks a lot what should i do to solve it

novainfinite gravatar imagenovainfinite ( 2018-12-21 05:28:11 -0500 )edit

Use the same metadata key. Set “metering.server_group” in the autoscaling group, or “stack” in the alarm definition.

Bernd Bausch gravatar imageBernd Bausch ( 2018-12-21 05:54:30 -0500 )edit

thanks a lot.i am so glad.you save me. i do not know how to apreciate you

novainfinite gravatar imagenovainfinite ( 2018-12-21 06:14:58 -0500 )edit

how can i learn how to write heat template. is there a book for it? i read about it in openstack.org but it is insufficient

novainfinite gravatar imagenovainfinite ( 2018-12-21 06:15:54 -0500 )edit

That’s how I learned it, and I didn’t even go through the entire template guide. Trial and error, mostly. Also, my knowledge is rather limited.

The problem with alarms has nothing to do with Heat though. I agree that linking alarms to groups of resources is not easy.

Bernd Bausch gravatar imageBernd Bausch ( 2018-12-21 06:34:31 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-12-20 12:29:45 -0500

Seen: 37 times

Last updated: Dec 22 '18