Ask Your Question
1

OpenStack Rocky - gnocchi-upgrade Failed

asked 2018-12-18 18:57:17 -0500

cconstantinou gravatar image

updated 2018-12-18 22:29:51 -0500

After installing Gnocchi plugin on OpenStack Rocky, it could not be possible to Initialize Gnocchi

stack@openstack:~/devstack$ gnocchi-upgrade
Traceback (most recent call last):
  File "/usr/local/bin/gnocchi-upgrade", line 11, in <module>
    sys.exit(upgrade())
  File "/usr/local/lib/python2.7/dist-packages/gnocchi/cli/manage.py", line 65, in upgrade
    conf = service.prepare_service(conf=conf, log_to_std=True)
  File "/usr/local/lib/python2.7/dist-packages/gnocchi/service.py", line 54, in prepare_service
    version=gnocchi.__version__)
  File "/usr/local/lib/python2.7/dist-packages/oslo_config/cfg.py", line 2127, in __call__
    self._check_required_opts()
  File "/usr/local/lib/python2.7/dist-packages/oslo_config/cfg.py", line 2865, in _check_required_opts
    raise RequiredOptError(opt.name, group)
oslo_config.cfg.RequiredOptError: value required for option url in group [indexer]

/etc/gnocchi/gnocchi.conf

[api]
auth_mode = keystone
keystone_authtoken]
...
auth_type = password
auth_url = http://x.x.x.x/identity
project_domain_name = Default
user_domain_name = Default
project_name = service
username = gnocchi
password = *********
interface = internalURL
region_name = RegionOne
[indexer]
url = mysql+pymysql://root:*********@127.0.0.1/gnocchi?charset=utf8
[Storage]
# coordination_url is not required but specifying one will improve
# performance with better workload division across workers.
coordination_url = redis://localhost:6379
file_basepath = /var/lib/gnocchi
driver = file
edit retag flag offensive close merge delete

Comments

I took the liberty to fix the formatting. Your question was close to unreadable. Please use the button labeled with "101010" to format code.

If the opening "[" in the [keystone_authtoken] line is missing, I guess Gnocchi is unable read the rest of the config file. Is this a typo in your question?

Bernd Bausch gravatar imageBernd Bausch ( 2018-12-18 22:31:27 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2018-12-19 10:59:15 -0500

updated 2018-12-19 10:59:30 -0500

This error occurs because this file oslo_config/cfg.py does not get "opt" correctly from function _check_required_opts .

I have corrected this error using:

sudo chmod 777 /etc/gnocchi/*

edit flag offensive delete link more
0

answered 2018-12-19 03:16:55 -0500

novainfinite gravatar image

updated 2018-12-19 03:18:23 -0500

you do not have redis comment it and use file instead of redis

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-12-18 18:49:50 -0500

Seen: 101 times

Last updated: Dec 19 '18