Openstack Multi Node external network problem

asked 2018-12-13 15:44:52 -0500

Mark14 gravatar image

updated 2018-12-14 16:58:16 -0500

Hello,

Could someone help me with external network configuration?

I am running Multi-Node Openstack environments

Home network: 172.12.0.0/24 with network access (router with DHCP and NAT)

Controller node - 172.12.0.10 Compute node - 172.12.0.20 Network node - 172.12.0.30

I deployed it through RDO. Answer file below: https://ufile.io/cauke

Could someone tell me how I need to configure external network to get internet access from instances?

I have 2 network

ext-network - 172.12.0.0/24 (type Flat, Physical Network "br-ex" as current interface name on network node, set as "External Network", Network 172.12.0.128/26 (for separate IPs), Gateway IP 172.15.0.1) int-network - 192.168.222.0/24 (type local)

In project I added Router and set gateway on ext-network and enable SNAT. I also add Interface to Router (internal and external).

Problem is that:

1) Internal Interface shows as "Active", and from instance I can ping router gateway - 192.168.222.1 2) Instance has not network access, external interface shows as "DOWN". traceroute is holding on 192.168.222.1 (internal gateway)

My question is in external network should I set gateway phisical router in network (172.12.0.1) or gateway as network node ip - 172.12.0.30 or something else? Something I miss?

edit retag flag offensive close merge delete

Comments

I can’t see your answer file because ufile.io doesn’t work with mobile Apple devices, but did you follow these instructions: https://www.rdoproject.org/networking...

I.e. you need to insert your home network interface in br-ex.

Bernd Bausch gravatar imageBernd Bausch ( 2018-12-13 16:28:51 -0500 )edit

Thanks for help! I just follow the instruction and it is work! ;) (I should disable DHCP while configuring new external network)

Mark14 gravatar imageMark14 ( 2018-12-14 16:57:38 -0500 )edit