Connectivity breaks between compute and controller [closed]

asked 2014-02-12 00:35:05 -0600

Akshat gravatar image

updated 2014-02-14 19:05:31 -0600

smaffulli gravatar image

Hi All,

I have a openstack setup(Grizzly) with 1 controller and multiple compute nodes. I am facing an issue where the connectivity of controller and one of the compute nodes breaks. The nova service-list command shows that compute as down.

I see the below error in the compute logs at the same time:

2014-02-11 03:06:16.216 28879 ERROR nova.servicegroup.drivers.db [-] model server went away
2014-02-11 03:06:16.216 28879 TRACE nova.servicegroup.drivers.db Traceback (most recent call last):
2014-02-11 03:06:16.216 28879 TRACE nova.servicegroup.drivers.db   File "/usr/lib/python2.6/site-packages/nova/servicegroup/drivers/db.py", line 88, in _report_state
2014-02-11 03:06:16.216 28879 TRACE nova.servicegroup.drivers.db     report_count = service.service_ref['report_count'] + 1
2014-02-11 03:06:16.216 28879 TRACE nova.servicegroup.drivers.db TypeError: 'NoneType' object is unsubscriptable

Also, restarting the nova-compute service on the compute node fixes the connectivity back.

Any pointers to debug this will be helpful.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by rbowen
close date 2016-09-28 14:36:54.933170

Comments

Closing: This question refers to a version of OpenStack which has been designated End Of Life. (See http://releases.openstack.org ). If the problem still exists in a more recent version, please open a new issue with updated details. Thanks.

rbowen gravatar imagerbowen ( 2016-09-28 14:36:50 -0600 )edit