flat public network ping/ssh fails for instances

asked 2018-12-06 12:02:52 -0600

I have installed OpenStack rocky stable release and have the following setup. I have configured a public network (.160/27, .190 gateway and no DHCP) based on the specific IP addresses allocated to my use. I have configured them as follows (.183 - host), (.163 - router gateway) and (.167, .184 - floating ips). In specific, .183 is assigned to em1 interface of the host (static ip defined in /etc/network/interfaces) on the host and bridge br-ex had the .161 automatically assigned on installation of openstack. Since I am not allocated that ip address by the network administrator, I have assigned the .163 (same as the router's gateway). The private network I have for the fixed ips of the VMs is 10.0.0.0/26.

I have launched a VM using the cirros image and that VM has been assigned the private fixed ip address 10.0.0.3. I have configured the VM to use the security group I defined with ingress rules for All ICMP, SSH and RDP rules enabled. I also was able to allocated the .167 floating IP address to the VM.

I can ping from the outside the host .183, the br-ex/router gateway at .163 but I cannot ping or ssh to the .167 floating ip of the VM. Two questions: 1. Should the br-ex and router gateway have the same .163 address or do they need to have different ip addresses? 2. If they need to have the same address then what is wrong with my setup? I cannot figure out any other problem.

Thanks, Achilleas

edit retag flag offensive close merge delete