Ask Your Question
0

neutron warning No controller found for: floatingips

asked 2018-12-05 02:00:14 -0600

soheil08 gravatar image

Hi,

I configured the OpenStack on two nodes,

  1. controller + network + storage + compute
  2. compute + storage

I started so many VMs on each and the overall working is fine.

The problem is in Neutron server.log it repeatedly writes the following lines:

2018-12-05 11:21:39.060 2214 INFO neutron.wsgi [req-f5aeb723-5653-4edd-9dce-2ddd54b5bf26 539929ca1549436cb4c4171e037e8df7 0a26c316d0d143229f7420cf7fa35bdc - default default] 192.168.0.32 "GET /v2.0/networks?id=a90d7d71-1ff4-4a98-b2b9-68adaea7d1c4 HTTP/1.1" status: 200  len: 877 time: 0.1932352
2018-12-05 11:21:39.067 2214 WARNING neutron.pecan_wsgi.controllers.root [req-21e4a83d-26c7-4eac-86c4-163a7cc2e224 539929ca1549436cb4c4171e037e8df7 0a26c316d0d143229f7420cf7fa35bdc - default default] No controller found for: floatingips - returning response code 404: PecanNotFound
2018-12-05 11:21:39.068 2214 INFO neutron.pecan_wsgi.hooks.translation [req-21e4a83d-26c7-4eac-86c4-163a7cc2e224 539929ca1549436cb4c4171e037e8df7 0a26c316d0d143229f7420cf7fa35bdc - default default] GET failed (client error): The resource could not be found.
2018-12-05 11:21:39.070 2214 INFO neutron.wsgi [req-21e4a83d-26c7-4eac-86c4-163a7cc2e224 539929ca1549436cb4c4171e037e8df7 0a26c316d0d143229f7420cf7fa35bdc - default default] 192.168.0.32 "GET /v2.0/floatingips?fixed_ip_address=192.168.0.210&port_id=69db0b54-c3f1-41a8-bd78-be64333d4444 HTTP/1.1" status: 404  len: 309 time: 0.0071781
2018-12-05 11:21:39.164 2214 INFO neutron.wsgi [req-645f2c12-9e58-4b6e-b0b5-3b682580bbc6 539929ca1549436cb4c4171e037e8df7 0a26c316d0d143229f7420cf7fa35bdc - default default] 192.168.0.32 "GET /v2.0/subnets?id=9771f7f2-12f8-46bd-aca3-f1d26e0b9768 HTTP/1.1" status: 200  len: 835 time: 0.0917201
2018-12-05 11:21:39.259 2214 INFO neutron.wsgi [req-7fcd4b7e-9f52-44af-915c-3cc0618609ee 539929ca1549436cb4c4171e037e8df7 0a26c316d0d143229f7420cf7fa35bdc - default default] 192.168.0.32 "GET /v2.0/ports?network_id=a90d7d71-1ff4-4a98-b2b9-68adaea7d1c4&device_owner=network%3Adhcp HTTP/1.1" status: 200  len: 1085 time: 0.0926280
2018-12-05 11:21:39.456 2214 INFO neutron.wsgi [req-6ec90519-59f9-4a63-ba95-462c19f2442d 539929ca1549436cb4c4171e037e8df7 0a26c316d0d143229f7420cf7fa35bdc - default default] 192.168.0.32 "GET /v2.0/networks/a90d7d71-1ff4-4a98-b2b9-68adaea7d1c4?fields=segments HTTP/1.1" status: 200  len: 212 time: 0.1940138
2018-12-05 11:21:39.654 2214 INFO neutron.wsgi [req-2f085296-16ce-4f5f-8d2c-d40ebfe631f6 539929ca1549436cb4c4171e037e8df7 0a26c316d0d143229f7420cf7fa35bdc - default default] 192.168.0.32 "GET /v2.0/networks/a90d7d71-1ff4-4a98-b2b9-68adaea7d1c4?fields=provider%3Aphysical_network&fields=provider%3Anetwork_type HTTP/1.1" status: 200  len: 281 time: 0.1963122

Actually I created an external Network (according to the documents) and VMs are run using that. The other detail is that I created a port (fixed IP) for each Instance (VMs) and assign it to the instance at initialization.

The main problem is the warning:

2018-12-05 11:21:39.067 2214 WARNING neutron.pecan_wsgi.controllers.root [req-21e4a83d-26c7-4eac-86c4-163a7cc2e224 539929ca1549436cb4c4171e037e8df7 0a26c316d0d143229f7420cf7fa35bdc - default default] No controller found for: floatingips - returning response code 404: PecanNotFound

How can I stop the warning?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2018-12-05 06:52:27 -0600

updated 2018-12-05 06:54:46 -0600

This will choose the web framework in which to run the Neutron API server. 'pecan' is a new rewrite of the API routing components.

Allowed values: legacy, pecan

web_framework = pecan

In neutron.conf , if you used pecan as a value for web_framework change that value to legacy

edit flag offensive delete link more

Comments

Hi, I checked the neutron.conf and there was no pecan or web_framework on the file. I applied all settings according to the document.

soheil08 gravatar imagesoheil08 ( 2018-12-05 08:00:45 -0600 )edit

I set web_framework = legacy, but it causes no change and neutron still logs!

soheil08 gravatar imagesoheil08 ( 2018-12-05 08:10:55 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-12-05 02:00:14 -0600

Seen: 41 times

Last updated: Dec 05