Ask Your Question
0

Openstack Cinder version not supported

asked 2018-12-01 15:55:12 -0600

Jitendra Selvam gravatar image

I am trying to create a cinder storage with a size of 5Gb and I get the following error.

# cinder create 5 --display-name FileStorage
ERROR: Version 3.52 is not supported by the API. Minimum is 3.0 and maximum is 3.50. (HTTP 406) (Request-ID: req-cc838137-0b60-4e72-8abe-a679a55aa399)

Is there any way I could get the cinder created ? I cannot change settings in openstack as I am not an admin. How do I go back version to 3.50 ?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2018-12-01 18:07:49 -0600

The cloud you are accessing seems to be Queens. The version of the cinder client you use to access may be Rocky or later, or the shell variable OS_VOLUME_API _VERSION may be set to 3.52.

Check the cinder client version with cinder --version.

Possible solutions:

  • Set OS_VOLUME_API_VERSION to 3.50 or run cinder --os-volume-api-version 3.50 5
  • Use the openstack client
  • Install the correct Cinder client
edit flag offensive delete link more

Comments

Wow thanks a lot ! Setting the OS_VOLUME_API_VERSION to 3.50 worked !

Jitendra Selvam gravatar imageJitendra Selvam ( 2018-12-02 01:18:56 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-12-01 15:55:12 -0600

Seen: 122 times

Last updated: Dec 01 '18