Ask Your Question
0

kolla ansible - instance no internet

asked 2018-11-28 00:10:07 -0500

Fayizal gravatar image

updated 2018-11-28 04:50:17 -0500

I am trying to setup an AIO using kolla-ansible and used below article as a starting point

https://blog.inkubate.io/install-and-configure-openstack-ocata-with-kolla-as-a-standalone/ (https://blog.inkubate.io/install-and-...)

I was able to finish the whole setup and login using horizon. However while launching the instance it seems it cannot connect to the internet.

below is status of br-ex through openvswitch

1(enp0s8): addr:08:00:27:60:1f:dc
     config:     0
     state:      0
     current:    1GB-FD COPPER AUTO_NEG
     advertised: 10MB-HD 10MB-FD 100MB-HD 100MB-FD 1GB-FD COPPER AUTO_NEG
     supported:  10MB-HD 10MB-FD 100MB-HD 100MB-FD 1GB-FD COPPER AUTO_NEG
     speed: 1000 Mbps now, 1000 Mbps max
 2(phy-br-ex): addr:1e:4b:f1:b3:b7:0c
     config:     0
     state:      0
     speed: 0 Mbps now, 0 Mbps max
 LOCAL(br-ex): addr:08:00:27:60:1f:dc
     config:     PORT_DOWN
     state:      LINK_DOWN
     speed: 0 Mbps now, 0 Mbps max
OFPT_GET_CONFIG_REPLY (xid=0x4): frags=normal miss_send_len=0

Instance IP address is 10.0.0.11 and I am able to reach router interface IP which is 10.0.0.1

Router is also connected to external network through external IP 10.230.12.221. I am able to ping this IP too. However the packets doesn't go after this

The host has 2 NIC's, enp0s3 and enp0s8

enp0s3 is management interface and enp0s8 is reserved for external communication for instances

edit retag flag offensive close merge delete

Comments

Hi, if you tcpdump on enp0s8 traffic appears? If yes, is an issue with physical interfaces or host networks(switches, routers, etc). If not, please share ovs-vsclt show and ofctl-dump flows br-ex within ovs containers

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2018-11-28 02:44:53 -0500 )edit

A correction to the blog used, public interface should be UP but without IP address, in the blog is assigned an IP address. The following config should match to your public IP ranges

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2018-11-28 02:47:06 -0500 )edit

8- Modify the public network scheme.

EXT_NET_CIDR='10.10.20.0/24'
EXT_NET_RANGE='start=10.10.20.110,end=10.10.20.254'
EXT_NET_GATEWAY='10.10.20.1'
Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2018-11-28 02:47:32 -0500 )edit

Thanks Eduardo,

This got resolved. I was using VM as a host and it needs promiscous mode to be ON to allow traffic through external network

Fayizal gravatar imageFayizal ( 2018-11-28 04:48:05 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2018-11-28 04:51:36 -0500

Fayizal gravatar image

I was using VM as a host and it needs promiscous mode to be ON to allow traffic through external network

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-11-28 00:10:07 -0500

Seen: 71 times

Last updated: Nov 28 '18