Ask Your Question
0

nova-compute rabbitmq fail to connect

asked 2013-05-15 04:10:47 -0600

polslinux gravatar image

I have a controller node and a compute node. On the compute node i installed nova-compute and ntp. The controller node ip is 17.25.27.11 and the compute node ip is 172.25.27.9.
This is my compute node nova.conf file:

[DEFAULT]
dhcpbridge_flagfile=/etc/nova/nova.conf
dhcpbridge=/usr/bin/nova-dhcpbridge
logdir=/var/log/nova
state_path=/var/lib/nova
lock_path=/var/lock/nova
force_dhcp_release=True
iscsi_helper=tgtadm
libvirt_use_virtio_for_bridges=True
connection_type=libvirt
root_helper=sudo nova-rootwrap /etc/nova/rootwrap.conf
verbose=True
ec2_private_dns_show_ip=True
api_paste_config=/etc/nova/api-paste.ini
volumes_path=/var/lib/nova/volumes
enabled_apis=ec2,osapi_compute,metadata
mysql_connection=mysql://nova:novaPass@172.25.27.11/nova
libvirt_type=kvm
compute_driver=libvirt.LibvirtDriver

# NETWORK
network_manager=nova.network.manager.FlatDHCPManager
flat_network_bridge=br100
flat_interface=eth0
flat_injected=False
fixed_range=172.25.100.0/24

# AUTHENTICATION
auth_strategy=keystone
[keystone_authtoken]
auth_host = 172.25.27.11
auth_port = 35357
auth_protocol = http
admin_tenant_name = service
admin_user = nova
admin_password = nova
signing_dirname = /tmp/keystone/signing-nova

# RABBITMQ
rabbit_host=172.25.27.11
rabbit_password=guest

# NOVNC CONSOLE
novncproxy_base_url=http://172.25.27.11:6080/vnc_auto.html
vncserver_proxyclient_address=172.25.27.9
vncserver_listen=172.25.27.9

# GLANCE
image_service=nova.image.glance.GlanceImageService
flance_api_servers=172.25.27.11:9292

# VOLUMES
volume_driver=nova.colume.driver.ISCSIDriver
volume_group=nova-volumes
volume_name_template=volume-%s

# SCHEDULER
compute_scheduler_driver=nova.scheduler.filter_scheduler.FilterScheduler

# APIS
osapi_compute_extension=nova.api.openstack.compute.contrib.standard_extensions
ec2_dmz_host=172.25.27.11
s3_host=172.25.27.11

The cmds:

  • nova image-list
  • glance index
  • nova flavor-list
  • ecc

works properly! But when i try to do sudo nova-manage service list on the compute node i got only the service nova-network with XXX.
So i looked in the nova-compute.log file and i have found that nova-compute always try to connect to locahost 5672 instead of 172.25.27.11 5672
I tried to telnet to 172.25.27.11 5672 and i'm able to connect to controller host from the compute host by after few seconds i got "connection close by foreign host" but if i try (on the compute node) to do telnet localhost 5672 i get this error message:

INFO nova.openstack.common.rpc.common [req-50086069-cdbc-41e1-a8bc-928aeedcf14c None None] Reconnecting to AMQP server on localhost:5672
2013-05-15 11:08:02.812 ERROR nova.openstack.common.rpc.common [req-50086069-cdbc-41e1-a8bc-928aeedcf14c None None] AMQP server on localhost:5672 is unreachable

So my problem is: how can i make nova-compute to connect to 172.25.27.11 instead of localhost for the rabbitmq service?

Thanks

edit retag flag offensive close merge delete

Comments

Same problem with me.

Yashjit gravatar imageYashjit ( 2013-12-13 04:44:47 -0600 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2013-05-15 04:32:34 -0600

fifieldt gravatar image

Hi,

Normally, I'd expect that setting rabbit_host to the correct IP (as you have) would solve this.

I note that 'localhost' is the default value for rabbit_host - is there a chance that you updated your nova.conf without restarting the services for the changes to take effect?

edit flag offensive delete link more

Comments

i give more than one time /etc/init.d/nova-compute restart and /etc/init.d/nova-network restart on compute node. I've also tried to restart rabbitmq server on the controller node :(

polslinux gravatar imagepolslinux ( 2013-05-15 04:35:43 -0600 )edit

Just for something different, try using rabbit_hosts=[' 172.25.27.11:5672'] ? (this is a configuration normally used for rabbit clustering, but shrug)

fifieldt gravatar imagefifieldt ( 2013-05-15 04:53:16 -0600 )edit

nothing change :(

polslinux gravatar imagepolslinux ( 2013-05-15 05:20:05 -0600 )edit

Your line:

dhcpbridge_flagfile=/etc/nova/nova.conf

Does not look right.

armando-migliaccio gravatar imagearmando-migliaccio ( 2013-05-15 06:04:38 -0600 )edit

why?? @armando

polslinux gravatar imagepolslinux ( 2013-05-15 06:46:14 -0600 )edit
0

answered 2013-05-15 05:33:11 -0600

For nova.conf file, you can simply copy it from controller node and change just couple of properties:

vncserver_proxyclient_address=your_compute_ip
enabled_apis=metadata

Second one is not set properly on your compute node. Also vlc listen points to your compute node instead of controller node:

vncserver_listen=your_controller_ip

For rabbit this: rabbit_host=172.25.27.11 should be ok, so you can try to purge nova-compute, restart all services on controller node and install it again, maybe that will help.

edit flag offensive delete link more

Comments

done...nothing change :-( but in the compute node have i to install rabbitmq? or only on the controller node have to be installed rabbitmq?

polslinux gravatar imagepolslinux ( 2013-05-15 05:39:06 -0600 )edit

You need just one rabbitmq on controller node.

Alen Komljen gravatar imageAlen Komljen ( 2013-05-15 05:43:30 -0600 )edit

uff what can i do now?

polslinux gravatar imagepolslinux ( 2013-05-15 05:45:36 -0600 )edit

You can try to go directly in database and delete that entry. Then restart all services on controller and compute nodes. (use nova; select * from services;)

Alen Komljen gravatar imageAlen Komljen ( 2013-05-15 05:55:55 -0600 )edit

@Alen: table nova.services doesn't exist O.o

polslinux gravatar imagepolslinux ( 2013-05-15 10:40:21 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-05-15 04:10:47 -0600

Seen: 4,790 times

Last updated: Dec 13 '13