Ask Your Question
0

Instance launch error. [closed]

asked 2018-11-26 05:35:24 -0600

star5 gravatar image

updated 2018-11-27 06:11:54 -0600

Setup Information: 1xController (name: controllerstack) 2xCompute nodes. (name: computestack, computestack2)

Network setup : NIC 1 (eth0) - 192.168.0.0/24 Network setup : NIC 2 (eth1) - 192.168.10.0/24 (has internet connection)

Setup guide being followed: Openstack Rocky Installation guide (https://docs.openstack.org/install-guide/ (https://docs.openstack.org/install-gu...)) Neutron Setup: Networking Option 1: Provider networks - https://docs.openstack.org/neutron/rocky/install/controller-install-option1-ubuntu.html (https://docs.openstack.org/neutron/ro...)

I am trying to create an instance from horizon on the controller and I get the following error

Error: Failed to perform requested operation on instance "c3", the instance has an error status: Please try again later [Error: Exceeded maximum number of retries. Exhausted all hosts available for retrying build failures for instance 05d7247e-c157-4744-82ba-8a73c5cb42ae.].

Logs on controller: nova-api.log : https://pastebin.com/CiYD3Pez apache2 error.log : https://pastebin.com/Fck0C0kt

Logs from compute: Nova-compute.log : https://pastebin.com/Www7vHcr

I haven't gone through the logs in each compute nodes. Any input would be valuable.

UPDATE:

Network created on openstack : https://imgur.com/a/6KcTgXL

SubNet: https://imgur.com/a/5ANATGP

neutron-server.log (updated): https://pastebin.com/EY4tTRhJ

response of ifconfig on controller: https://imgur.com/a/qDGHhda Note: eth0 is all connected to a switch. eth1 is connected to another switch with Internet connection.

ml2_conf.ini (controller): https://pastebin.com/gik8c5G2

linuxbridge_agent.ini (controller): https://pastebin.com/QRCDtJ97

ml2_conf.ini (compute node1): https://pastebin.com/tfXybJpu

linuxbride_agent.ini (compute node1): https://pastebin.com/Xqxf2EwY

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by star5
close date 2018-12-01 06:49:47.452543

Comments

The launch fails because Nova is unable to create a volume in time. novainfinite’s answer may help. If not:

Did you set up the volume service? Can you create volumes? If not, either complete volume service setup, or launch the instance without volume.

Bernd Bausch gravatar imageBernd Bausch ( 2018-11-26 06:16:42 -0600 )edit

Yes I did try without the volume and it gives me another error. Added to the original post. I will try to fix the volume setup though. But even without the volume it gives me error.

star5 gravatar imagestar5 ( 2018-11-26 08:43:54 -0600 )edit

the 2nd error means that the instance launch failed on all compute nodes that were tried. Failure details in the nova compute log(s) and/or libvirt log(s).

Bernd Bausch gravatar imageBernd Bausch ( 2018-11-26 08:58:06 -0600 )edit

I have added the nova compute log from one of the compute nodes. I can see a neutron error in there. Is that the problem?

star5 gravatar imagestar5 ( 2018-11-26 09:43:06 -0600 )edit

I have checked the config logs in the controller and compute nodes for nova and it is perfect.

star5 gravatar imagestar5 ( 2018-11-26 10:01:48 -0600 )edit

3 answers

Sort by » oldest newest most voted
0

answered 2018-11-26 06:07:30 -0600

yasin lachiny gravatar image

what is the size of your image? add block_device_allocate_retries=6000 to nova.conf

edit flag offensive delete link more

Comments

Its the default Cirros that I tried.

star5 gravatar imagestar5 ( 2018-11-26 08:42:56 -0600 )edit
0

answered 2018-11-27 01:18:59 -0600

updated 2018-11-27 01:19:18 -0600

  1. check the core service is running by typing command " netstat -an | grep LISTENING". In the controller node,it should contains listening port 8778(placement_api service), 8774(compute-service),9292(Image service),9696(network),5000(Identify service),5672(rabbitmq server), 11211( memcache server),35357(Identify service)

    2.confirm that you have enough resources to allocate your instance, if enough resource available, then the issue comes from networking (neutron) and not from Nova itself. (Trace neutron logs for "PortBindingFailed")

    3.check your host's hardware supports virtualization or not by issuing "virt-host-validate",if fails change to virt_type to qemu

edit flag offensive delete link more

Comments

1) None of these ports are listed in the response. But I have created all the services and their endpoints and I can access all of them on the browser.

2) Yes I have enough resources.

3) My hardware does support virtualization. But nonetheless I have kept virt_type to qemu.

star5 gravatar imagestar5 ( 2018-11-27 06:15:37 -0600 )edit
0

answered 2018-11-28 03:52:20 -0600

Your Neutron log contains

2018-11-26 12:49:11.524 2261 ERROR neutron.plugins.ml2.managers [req-8702d340-da32-4e78-8f47-7f67294a131e ab6ad8a6ab9b4eff85e0438de6cbf1a7 2b35c39f3f744ea18aee07c8f2d4124e - default default] Failed to bind port 93122ccb-bcea-46ca-9e6e-a16f968406f4 on host computestack for vnic_type normal using segments [{'network_id': 'b7a8108c-63b5-4c67-9960-07c1cf8b9ca0', 'segmentation_id': None, 'physical_network': u'eth0', 'id': '90e498d9-8a43-4509-8da5-2bb6145f0615', 'network_type': u'flat'}]

Note the physical_network: It's called eth0.

In both Linuxbridge configs, however, you have

physical_interface_mappings = provider:eth1

Here, the physical network is named provider.

When you created the external network, you should have used option --provider-physical-network provider, not --provider-physical-network eth0. I wonder, by the way, why Neutron allowed you to use an invalid provider network name. Perhaps I miss something.

edit flag offensive delete link more

Comments

In this explanation: https://docs.openstack.org/neutron/rocky/install/controller-install-option1-ubuntu.html (https://docs.openstack.org/neutron/ro...) The linux bridge is supposed to be :physical_interface_mappings = provider:PROVIDER_INTERFACE_NAME . And according to my setup management interface = eth0 and provider interface = eth1.

star5 gravatar imagestar5 ( 2018-11-28 10:19:30 -0600 )edit

What I am trying to do is to get two clouds setup and their instances communicate with each other. I don't know what network type should I setup: Networking option 1 or networking option 2 mentioned here (https://docs.openstack.org/install-guide/overview.html (https://docs.openstack.org/install-gu...)) ??

star5 gravatar imagestar5 ( 2018-11-28 10:21:34 -0600 )edit

Both options work, but both options require correct setup of the external network.

Bernd Bausch gravatar imageBernd Bausch ( 2018-11-28 10:26:46 -0600 )edit

Should I be creating a bridge between the NICs before setting up neutron on the controller and compute. I am trying a fresh install again.

star5 gravatar imagestar5 ( 2018-11-29 01:07:51 -0600 )edit

No. The installation guide assumes two separate networks. You configure one as the provider network to give instances access to the world outside of the cloud. In your case that seems to be eth1.

Bernd Bausch gravatar imageBernd Bausch ( 2018-11-29 01:27:00 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-11-26 05:34:52 -0600

Seen: 826 times

Last updated: Nov 28 '18