Provider network not working !!?

asked 2018-11-26 05:03:05 -0500

Park Kyung Won gravatar image


I have this setup now: Ubuntu 18.04 one controller node has keystone, DB, horizon ... neutron controller one storage node has cinder other compute nodes have neutron and nova I've installed openstack rocky from ubuntu repository

All nodes(controller and compute nodes) has two interfaces, management(MGMT) and data(DATA) MGMT interface is connected to management switch and DATA interface is connected to data switch and data switch is connected to physical router(

What I can do: - I can create provider network - I can create self-service network - I can attach my VM instance to both provider or self-service network - My VM gets IP from openstack DHCP service - VMs can ping each other when they are in the same self-service network - VMs can ping to gateway in self-service network, which is virtual router made in openstack

What I can't: - I can't get connectivity to external world - When my VM is directly attached to the provider network subnet I've made(, it cannot ping gateway(, which is the physical router connected to the physical switch(data switch)

At router, there is no evidence of any packet coming from VMs ( net) How can I fix this?...

edit retag flag offensive close merge delete


what is your linux-bridge agent log?

yasin lachiny gravatar imageyasin lachiny ( 2018-11-26 06:08:21 -0500 )edit

There is nothing special about it...

Park Kyung Won gravatar imagePark Kyung Won ( 2018-11-26 06:42:53 -0500 )edit

My guess is that the mapping from your Neutron provider network to the physical network is incorrect. This mapping is done in the configuration of your ML2 mechanism driver, in most cases either Linuxbridge or Openvswitch. Check both controller and compute nodes. It is easy to get this wrong.

Bernd Bausch gravatar imageBernd Bausch ( 2018-11-27 21:13:31 -0500 )edit

You were correcr. I fixed this and the answer was tather simple... The provider network interface was down

Park Kyung Won gravatar imagePark Kyung Won ( 2018-11-27 22:13:01 -0500 )edit