Ask Your Question
0

Ironic network config - cannot locate tftp file

asked 2018-11-23 21:53:13 -0500

JL gravatar image

I have an all-in-one setup with kolla-ansible (using 7.0.0), with ironic enabled.

I am trying to use ironic to install machines, but they can never find their config file. The target machine will boot, DHCP to get an address, and then fail to download a config file over TFTP. Tcpdump shows it is definitely trying.

The network which the target machine gets a DHCP address on is the one connected to "enp0s25" (the "network_interface" setting in globals.yml), and the address it gets is in the "ironic_dnsmasq_dhcp_range" range. This interface is not tied to any network object in openstack.

When I define the machine in horizon, I am using an external network "public1" (on "physnet1", on "br-ex", on "enp0s25.202"). That is not the same network as the DHCP service is on, which is suspicious to me - but I can't see how I can define it to match.

I am using the staging-wol driver, as I have no separate BMC.

I can't figure this out. Do I have the network configured incorrectly in some way? Are the tftp config files available, if my machine was asking in some different way? Where should I look to diagnose this?

Thanks, -- JL

/etc/kolla/globals.yml:

---
docker_registry: "192.168.2.1:5001"
kolla_internal_vip_address: "192.168.2.10"
kolla_external_vip_address: "192.168.1.101"
kolla_install_type: "binary"
network_interface: "enp0s25"
neutron_external_interface: "enp0s25.202"
kolla_external_vip_interface: "wlp2s0"

enable_ironic: "yes"
enable_ironic_ipxe: "yes"
ironic_dnsmasq_dhcp_range: "192.168.2.100,192.168.2.199"
ironic_cleaning_network: "public1"  # ???
ironic_dnsmasq_boot_file: pxelinux.0
ironic_ipxe_port: "8089"
...
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2018-11-24 19:05:17 -0500

JL gravatar image

I have figured it out.

What I had not understood was that enabling iPXE effectively disables PXE, and that iPXE only works with compatible hardware.

I could see the TFTP files appearing in /httpboot, (which is for iPXE), but not in /tftpboot (which is for PXE).

Changing enable_ironic_ipxe to "no" and re-deploying solved the problem.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-11-23 21:53:13 -0500

Seen: 26 times

Last updated: Nov 23 '18