Ask Your Question
0

HOST_IP change in OpenStack Pike, cannot log into Dashboard

asked 2018-11-23 05:37:36 -0500

SilviuT gravatar image

Hello. I have installed openstack pike on my local machine using devstack. I have downloaded Ubuntu 16.04 OS and then followed the procedure. Downloaded devstack, specified the necessary elements and HOST_IP in the local.conf and hit ./stack.sh. Everything worked.

Unfortunately now I am in another network and using another IP for the host. I have researched on google how to change IP, but nothing worked and I cannot log into the Openstack Dashboard. I have looked in keystone log and see that it still uses the old IP. I have changed the IP in the database, re-run ./stack.sh. Nothing works. Of course, I didn't found any resolution for OpenStack Pike. All the resolutions used rejoin-stack.sh, which is no longer present in my version.

Please, what are the steps that I need to use, for my OpenStack distribution, to be able to access the environment if I change network and implicitly the IP.

Thank you and I really hope that you can help me. Silviu

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2018-11-23 11:43:12 -0500

updated 2018-11-23 11:44:37 -0500

stack.sh was not designed to be re-run, and the host’s IP is used in too many places to change it manually. To ensure that any trace of the old IP address is wiped out, I suggest reinstalling the OS, then installing Devstack with the new HOST_IP.

edit flag offensive delete link more

Comments

I am working with OpenStack for my PhD and I want to make a test environment using OpenStack to learn. I am using my laptop and the host IP from my laptop may vary due to the Network I am using. Is there any way to accommodate that or simply install it in a fixed place and that is it? Thank you.

SilviuT gravatar imageSilviuT ( 2018-11-26 02:58:22 -0500 )edit

OpenStack expects static addresses. You can, however, either set it up in a virtual machine (strongly recommended anyway for an environment as invasive as Devstack) and give it a static address in the virtual network. Or it should be possible add a 2nd, static address to your network interface.

Bernd Bausch gravatar imageBernd Bausch ( 2018-11-26 06:07:47 -0500 )edit

Thank you very much Bernd. I am using an Ubuntu VM. When installed the Openstack used X.X.1.248 IP. Now, in another network, the VM has another IP. If I will setup the second interface with X.X.1.248, the dashboard should now open, right? I will test that and let you know. Thank you once again.

SilviuT gravatar imageSilviuT ( 2018-11-26 07:13:09 -0500 )edit

setup an isolated /routed VM network and configure your VM with a static address.

Bernd Bausch gravatar imageBernd Bausch ( 2018-11-26 09:02:28 -0500 )edit

Hi Bernd.In virtual box I have created also a NAT interface and used that IP for OpenStack and it works.Now, I have another problem. Cannot access the compute instance with floating IP from the OpenStack host: Destination Unreachable? What should I do? It really works only with bridged mode? Thanks

SilviuT gravatar imageSilviuT ( 2018-12-04 14:57:50 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-11-23 05:37:36 -0500

Seen: 53 times

Last updated: Nov 23 '18