Ask Your Question
0

VM stalls with the console log "Exiting boot services and installing virtual address map"

asked 2018-11-21 07:05:56 -0500

srik1782 gravatar image

updated 2018-11-21 07:11:32 -0500

Hi, I am working with OpenStack stable/pike release in Ubuntu 18.04. I am able to register my compute in the Openstack Controller. When I am trying to spawn VM, which is worked in the earlier OpenStack releases, VM is stalled with the following log in the VM console logs:

EFI stub: Booting Linux Kernel...
EFI stub: Generating empty DTB
EFI stub: Exiting boot services and installing virtual address map...

I am observing that VM is in Running status, without any error logs. And, VM is booting with UEFI support. Earlier I didn't observe this. How can I disable UEFI support, while spawning VM's in OpenStack Nova-Compute.

My Libvirt version is 4.0.0. Can someone help me to fix the issue.

Regards, Srikanth.

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2018-11-21 08:08:41 -0500

updated 2018-11-21 08:11:53 -0500

The primary work items are

1)Add the ‘hw_firmware_type’ field to the ImageMetaProperties object

2)Update the libvirt guest XML configuration when the UEFI image property is preset

(hw_firmware_type=uefi)-This indicates that which kind of firmware type will be used to boot VM. This property can be set to ‘uefi’ or ‘bios’

ref: https://specs.openstack.org/openstack...

OpenStack image create --container-format bare --disk-format qcow2 \ --property hw_firmware_type=uefi --file /tmp/cloud-uefi.qcow --name uefi

ref : https://docs.openstack.org/glance/pik...

DEFAULT_UEFI_LOADER_PATH maybe /usr/share/OVMF/OVMF_CODE.fd”}-Changing this maybe help you to change hw_firmware_type

changing flavor for boot mode (uefi or bios) - --> openstack flavor set --property capabilities:boot_mode='uefi'

edit flag offensive delete link more

Comments

Hi, I added the glance image with the property "hw_firmware_type=uefi". And also, I added a flavor with the property "capabilities:boot_mode='uefi'" and spawned the VM. But, still I am facing the same issue. When I saw the libvirt driver code, hw_firmware_type is hard coding to uefi.

srik1782 gravatar imagesrik1782 ( 2018-11-21 11:22:58 -0500 )edit

So, even though we don't set the image property hw_firmware_type=uefi, its hard coded to uefi. Libvirt driver by default spawning the VM with UEFI. Is there any way to spawn VM with out UEFI? I didn't observe this behavior in the previous releases of Libvirt/OpenStack.

srik1782 gravatar imagesrik1782 ( 2018-11-21 11:25:22 -0500 )edit

try hw_firmware_type=bios

Eranachandran gravatar imageEranachandran ( 2018-11-21 22:56:24 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-11-21 07:05:56 -0500

Seen: 313 times

Last updated: Nov 21 '18