Ask Your Question
0

Error: /Stage[main]/Neutron::Db::Sync/Exec[neutron-db-sync]: Failed to call refresh: Command exceeded timeout

asked 2018-11-20 08:40:48 -0500

Alin Parashar gravatar image

Getting this error while installing Openstack Rocky with Packstack 172.26.248.160_controller.pp: [ ERROR ]
Applying Puppet manifests [ ERROR ]

ERROR : Error appeared during Puppet run: 172.26.248.160_controller.pp Error: /Stage[main]/Neutron::Db::Sync/Exec[neutron-db-sync]: Failed to call refresh: Command exceeded timeout

Following are the commands that I am using:- 1. systemctl disable/stop firewalld 2. systemctl disable/stop NetworkManager 3. systemctl enable/start network 4. setenforce 0 5. yum install -y centos-release-openstack-rocky 6. yum update -y 7. yum install -y openstack-packstack 8. packstack --gen-answer-file=/root/answers.txt 9. packstack --answer-file=/root/answers.txt --timeout=600

My config in answer file CONFIG_HEAT_INSTALL=y http://CONFIG_NTP_SERVERS=time1.google.com,time2.google.com (CONFIG_NTP_SERVERS=time1.google.com,t...) CONFIG_CONTROLLER_HOST=172.26.248.160 CONFIG_COMPUTE_HOSTS=172.26.248.160 CONFIG_NETWORK_HOSTS=172.26.248.160 CONFIG_KEYSTONE_ADMIN_USERNAME=admin CONFIG_KEYSTONE_ADMIN_PW=password CONFIG_NEUTRON_L3_EXT_BRIDGE=br-ex CONFIG_NEUTRON_ML2_TYPE_DRIVERS=vxlan,flat,vlan CONFIG_NEUTRON_ML2_TENANT_NETWORK_TYPES=vlan CONFIG_NEUTRON_ML2_VLAN_RANGES=extnet:1100:1199 CONFIG_NEUTRON_OVS_BRIDGE_MAPPINGS=extnet:br-ex CONFIG_NEUTRON_OVS_BRIDGE_IFACES=br-ex:em1 CONFIG_NEUTRON_OVS_BRIDGES_COMPUTE=br-em1 CONFIG_PROVISION_DEMO=n CONFIG_PROVISION_TEMPEST=n

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2018-11-21 05:58:35 -0500

Alin Parashar gravatar image

nova-manage.log indicated the timeout was after 5 minutes; So the setting on the packstack command line isn't used in the nova db sync puppet manifest.

found it in: /usr/share/openstack-puppet/modules/nova/manifests/db/sync.pp in sync.pp I changed $db_sync_timeout = 300 to $db_sync_timeout = 900

and execute 'packstack' again. Now it hits the same issue with neutron db sync.. same solution timeout in the manifest put on 900 and now it is installed

conclusion: has to do with performance / load probably (I/O's?)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-11-20 08:40:48 -0500

Seen: 781 times

Last updated: Nov 21 '18