Ask Your Question
1

Juju OpenStack VM paused automatically after deploying successfully

asked 2018-11-15 02:08:00 -0500

NickHo gravatar image

updated 2018-11-15 07:50:58 -0500

Hello all,

I'm trying the OpenCORD Cord in a box installation, which used juju openstack to realize NFV environment. Actually I had completed the deployment several times on server and all the OpenStack VNF VM runs well by nova.

But when I changed the machine from a server to a workstation with the same specification of hardware, I faced some problem.

When I do some test by using the nova compute to create VM, the VM will show running. After several minutes, all the VMs becomes paused automatically. I re-install juju OpenStack several times but still no luck.

The attachment is the log of nova-compute.

It shows

"ERROR oslo_messaging._drivers.impl_rabbit [req-d54aba61-d5a2-4539-a8d7-8b8f8c44db8a - - - - -] AMQP server on 127.0.0.1:5672 is unreachable: [Errno 111] ECONNREFUSED. Trying again in 2 seconds."" for several times

logs: nova-compute.log

Nova output:

vagrant@head1:~$ nova list --all-tenants
+--------------------------------------+-----------------+--------+------------+-------------+-------------------------------------------------------------------------+
| ID                                   | Name            | Status | Task State | Power State | Networks                                                                |
+--------------------------------------+-----------------+--------+------------+-------------+-------------------------------------------------------------------------+
| 93f7f99d-ebd1-444b-9810-df0db9e9e76f | mysite_oaibbu-1 | ACTIVE | -          | Paused      | management=172.27.0.2; public_network=10.8.1.2; oaibbu_network=10.0.4.2 |
| 94425a38-9e35-47e5-ac65-ce4374737531 | mysite_vhss-3   | ACTIVE | -          | Paused      | management=172.27.0.4; vhss_network=10.0.7.2                            |
| 1abba20f-9dc2-473d-a9b8-10001d76fd64 | mysite_vmme-2   | ACTIVE | -          | Paused      | management=172.27.0.3; vmme_network=10.0.6.2                            |
| e2f01e9b-757e-4d1e-876e-8480d704c796 | mysite_vspgwc-4 | ACTIVE | -          | Paused      | management=172.27.0.5; vspgwc_network=10.0.8.2                          |
| 623d585e-3335-4ec0-8d03-4cbf7975c955 | mysite_vspgwu-5 | ACTIVE | -          | Paused      | management=172.27.0.6; public_network=10.8.1.3; vspgwu_network=10.0.9.2 |
+--------------------------------------+-----------------+--------+------------+-------------+-------------------------------------------------------------------------+

Any help will be appreciated,

Nick.

edit retag flag offensive close merge delete

Comments

AMQP server on 127.0.0.1:5672 is unreachable might be a temporary condition while the cloud is starting up. If you are sure that this message correlates with your problem, check if the AMQP server, normally RabbitMQ, is running, and if yes what prevents nova-compute from talking to it.

Bernd Bausch gravatar imageBernd Bausch ( 2018-11-15 03:05:58 -0500 )edit

Actually I'm not sure whether this correlates my problem, but this is the only problem that I can found in the log. I'm still confused why the service VM can be created and the status is running at initial, but after arround 10 minute, all the service's power state became paused.

NickHo gravatar imageNickHo ( 2018-11-15 06:20:17 -0500 )edit

The status is ACTIVE. I understand that the hypervisor manages the power state, not Nova (https://wiki.openstack.org/wiki/VMState). Is there something in the instance that pauses it?

Or check the hypervisor’s log. You may have to increase the log level of livirt (if that’s your hypervisor).

Bernd Bausch gravatar imageBernd Bausch ( 2018-11-17 04:14:53 -0500 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2018-11-15 03:17:32 -0500

updated 2018-11-15 03:22:48 -0500

check rabbit-mq status and rabbit-mq logs.check the rabbit-mq credential in nova configuration file .some times restarting rabbit-mq will fix the problem, restart rabbit-mq by service rabbitmq-server restart.

check port 5672 is active or blocked

edit flag offensive delete link more

Comments

I did the rabbitmq-server restart, and use netstat to check 5672 is active, I also disable the ufw. ERROR oslo_messaging._drivers.impl_rabbit AMQP server on rabbitmq-server.cord.lab:5671 is unreachable: [Errno 111] ECONNREFUSED. Trying again in 2 seconds. But now still no luck. the log become this

NickHo gravatar imageNickHo ( 2018-11-15 06:23:25 -0500 )edit

create another rabbit-mq user and change rabbit-mq credentials in config files and try

    rabbitmqctl add_user openstack RABBIT_PASS

    rabbitmqctl set_permissions openstack ".*" ".*" ".*"
Eranachandran gravatar imageEranachandran ( 2018-11-15 07:57:58 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-11-15 02:00:17 -0500

Seen: 70 times

Last updated: Nov 15 '18