Ask Your Question
3

Ubuntu OpenStack wrong interface

asked 2018-11-14 03:30:20 -0500

RyanW17 gravatar image

So I've recently installed OpenStack on Ubuntu 16.04 using conjure-up using this documentation (https://www.ubuntu.com/openstack/install) However, I've just restarted my server and I'm unable to access the dashboard, I believe its something to do with the NICs that juju/openstack is using. Below is the output of the lxc profile. It seems that its using NICs eth0 and eth1 but I do not have those on my machine, the only interface I have is eno1 operating on a private IPv4 address of 192.168.0.3.

Before I restarted my server I setup NAT rules using ip tables using the below command, this worked fine and I was able to access the openstack dashboard via 192.168.0.3 from a computer on the same network. However the dashboard was super slow so I restarted the machine, and now nothing works.

   78  sudo iptables -t nat -A PREROUTING -p tcp -d 192.168.0.3 --dport 80 -j DNAT --to-destination 10.175.147.16:80
   87  sudo iptables -t nat -A PREROUTING -p tcp -d 192.168.0.3 --dport 443 -j DNAT --to-destination 10.175.147.16:443

Below is the lxc profile show command

ryan@ubuntu:/etc/network$ lxc profile show juju-conjure-openstack-novalx-b5f
    config:
      boot.autostart: "true"
      linux.kernel_modules: openvswitch,nbd,ip_tables,ip6_tables,netlink_diag
      raw.lxc: |
        lxc.apparmor.profile=unconfined
        lxc.mount.auto=sys:rw
      security.nesting: "true"
      security.privileged: "true"
    description: ""
    devices:
      eth0:
        nictype: bridged
        parent: lxdbr0
        type: nic
      eth1:
        nictype: bridged
        parent: conjureup0
        type: nic
      root:
        path: /
        pool: default
        type: disk
    name: juju-conjure-openstack-novalx-b5f
    used_by:
    - /1.0/containers/juju-aee0f7-0
    - /1.0/containers/juju-aee0f7-1
    - /1.0/containers/juju-aee0f7-2
    - /1.0/containers/juju-aee0f7-3
    - /1.0/containers/juju-aee0f7-4
    - /1.0/containers/juju-aee0f7-5
    - /1.0/containers/juju-aee0f7-6
    - /1.0/containers/juju-aee0f7-7
    - /1.0/containers/juju-aee0f7-9
    - /1.0/containers/juju-aee0f7-10
    - /1.0/containers/juju-aee0f7-8
    - /1.0/containers/juju-aee0f7-11
    - /1.0/containers/juju-aee0f7-15
    - /1.0/containers/juju-aee0f7-13
    - /1.0/containers/juju-aee0f7-12
    - /1.0/containers/juju-aee0f7-14
    - /1.0/containers/juju-aee0f7-16
    ryan@ubuntu:/etc/network$
edit retag flag offensive close merge delete

Comments

If you are using MaaS try going to settings-> general and for Global Kernel Parameters put: net.ifnames=0 biosdevname=0

Then redeploy, this will rename the interfaces to eth0/eth1 which will coincide with the install information.

reynoni gravatar imagereynoni ( 2018-11-14 09:56:58 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2018-11-16 08:22:40 -0500

reynoni gravatar image

I just saw your note about IP table rules. Did you make these rules persistent before the reboot? I'm pretty they get erased on a reboot. Try adding the rules back in and see if it works. I've noticed that most of the openstack auto-deployment tools do try to use eth0/eth1 rather than eno, and so I have started configuring all systems to use the eth0/eth1 naming convention. If that's not possible, there should be flags in the conjure-up process that allow you to set eno as the taget instead of eth.

Look to my comment on the question to use MAAS to set the interfaces properly.

edit flag offensive delete link more
0

answered 2018-11-16 12:08:53 -0500

I have installed the open stack in my laptop with windows 10 but it is not working in my laptop, I thought that it may be the system issue but after consulting with https://babasupport.org/windows/fix-windows-10-error-code-0x8024a105/ (windows error code 0x8024a105) I got to know that there is not any fault in the system. can anyone suggest me the solution?

edit flag offensive delete link more

Comments

Please submit a new question for an answer, commenting on an existing question like this with a new question is not the best or proper way to do this.

reynoni gravatar imagereynoni ( 2018-11-19 06:45:36 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-11-14 03:30:20 -0500

Seen: 117 times

Last updated: Nov 16 '18