Ask Your Question
0

Failed to login to dashboard

asked 2018-11-13 04:07:17 -0600

najeh gravatar image

i perform a manual installation and everything is working fine, but after the installation of the dashboard service i access to the login page, the login is successful but the dashboard doesn't load.

This is my /var/log/apache2/error.log file :

[Tue Nov 13 12:04:01.649013 2018] [wsgi:error] [pid 14121:tid 139935807813376] [remote x.x.x.x:50538] INFO openstack_auth.forms Login successful for user "admin" using domain "default", remote address x.x.x.x.

edit retag flag offensive close merge delete

Comments

You should also have a horizon log /var/log/apache2/horizon_access.log and horizon_error.log. Or whatever log is configured in /etc/apache2/sites-enabled/horizon.conf.

Bernd Bausch gravatar imageBernd Bausch ( 2018-11-13 05:13:50 -0600 )edit

i didn't find any file with the name "horizon*" find ~/ -type f -name horizon = None should i reinstall the dashboard service

najeh gravatar imagenajeh ( 2018-11-13 06:10:27 -0600 )edit

Why are you looking for a file named horizon? On my system, they are named horizon_error.log and horizon_access.log. The log files are configured in /etc/apache2/sites-enabled/horizon.conf.

Bernd Bausch gravatar imageBernd Bausch ( 2018-11-13 06:32:58 -0600 )edit

but i haven't an /etc/apache2/sites-enabled/horizon.conf file or any other file named horizon_error.log or horizon_access.log

najeh gravatar imagenajeh ( 2018-11-13 07:11:03 -0600 )edit

Well, to view the horizon log, you need to find it. The paths are probably defined in Horizon’s Apache configuration. It must be somewhere.

Bernd Bausch gravatar imageBernd Bausch ( 2018-11-13 07:44:06 -0600 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2018-11-13 05:49:58 -0600

updated 2018-11-13 06:04:30 -0600

/etc/openstack-dashboard/local_settings.py

change 'location': '127.0.0.1:11211', to  'controller:11211' or 'controller_ip:11211'

In /etc/apache2/apache2.conf

<Directory />
            Options FollowSymLinks
            AllowOverride all
            Require all granted
</Directory>
<Directory /usr/share>
            AllowOverride all
            Require all granted
</Directory> 
<Directory /var/www/>
            Options Indexes FollowSymLinks
            AllowOverride None
            Require all granted
</Directory>
edit flag offensive delete link more

Comments

i have the settings but failed

najeh gravatar imagenajeh ( 2018-11-13 06:19:18 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-11-13 04:07:17 -0600

Seen: 44 times

Last updated: Nov 13