Ask Your Question
0

magnum create cluster volumeType error

asked 2018-11-12 08:26:46 -0500

amfgomez gravatar image

updated 2018-11-13 01:49:57 -0500

Hello I am using Packstack-queens and I am trying to deploy a docker swarm cluster with magnum.

This is my cluster template:

Cluster Type COE swarm
Cluster Distro fedora-atomic
Server Type VM
Público Sí
Registry Enabled Sí
TLS Disabled No
Node Spec
Image ID Fedora-atomic-lates
Keypair testKey
Flavor ID m1.medium
Master Flavor ID m1.small
Volume Driver rexray
Docker Storage Driver devicemapper
Docker Volume Size10gb
Insecure Registry
Red Network Driver docker
HTTP Proxy
HTTPS Proxy
No Proxy
External Network ID 1e37dc1b-391f-4dd7-ad83-b53eeda6c2f5
Fixed Network be0a019e-4866-413f-8bc1-35fe888f29dd
Fixed Subnet 51a0efc1-5307-43f5-827f-d79ecdc2d291
DNS 8.8.8.8
Master LB Enabled No
Floating IP Enabled Sí
When I launch the cluster, Openstack response me with the following error:

Resource CREATE failed: resources[0]: resources.swarm_masters.Property error:

resources.docker_volume.properties.volume_type: Error validating value '': The VolumeType () could not be found

In /etc/magnum/magnum.conf section Cinder:

default_docker_volume_type = iscsi

Openstack disk space is :

385GB/1000 GB in volume

485GB/1,5TB in Local Disk

edit retag flag offensive close merge delete

Comments

Similar question, where the problem was caused by lack of storage space: https://ask.openstack.org/en/question....

By the way, format your code as code. The way your question is formatted, it's largely impossible to read.

Bernd Bausch gravatar imageBernd Bausch ( 2018-11-12 20:50:14 -0500 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2018-12-06 20:29:16 -0500

Hi, I met a similar issue before, it was caused by my missing default_docker_volume_type option in /etc/magnum/magnum.conf. For your case, given that you have already set it to default_docker_volume_type = iscsi, I would suggest to make sure iscsi is a valid volume type in cinder (checking by cinder type-list), and also make sure you've restarted your magnum services after updating your /etc/magnum/magnum.conf to let it take effect. Good luck! : )

Yang

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-11-12 08:26:46 -0500

Seen: 252 times

Last updated: Nov 13 '18