Ask Your Question
0

IP is not getting assigned when using ML2/icehouse

asked 2014-02-10 03:20:59 -0500

Sudheesh gravatar image

updated 2014-11-20 04:33:35 -0500

dbaxps gravatar image

I am using Ml2 plugin and icehouse release.

I have configured a Controller and compute nodes (KVM hpyervisor). I have Cent OS and Cirros images configured in my controller.

Following is the configurations

/etc/neutron/plugins/ml2/plugin.ini (Which is linked to /etc/neutron/plugin.ini)

[ml2]
type_drivers = flat
mechanism_drivers = openvswitch
tenant_network_types = flat

I am trying to use flat network type intially and then move to vlan type

[ml2_type_flat]
flat_networks = physnet1

I have following configurations in  /etc/neutron/neutron.conf
[DEFAULT]
core_plugin = neutron.plugins.ml2.plugin.Ml2Plugin
service_plugins = neutron.services.l3_router.l3_router_plugin.L3RouterPlugin

And in agent side I have

/etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini
[ovs]
bridge_mappings = physnet1:br-eth0

   ovs-vsctl add-br br-eth0
    ovs-vsctl add-port br-eth0 eth1

    service neutron-openvswitch-agent restart
    service neutron-dhcp-agent restart

And

#  ovs-vsctl show
61b686f2-1cac-4fa8-98ca-aaee2c3fb753
    Bridge br-int
        Port "tap0ddbbe12-d1"
            tag: 2
            Interface "tap0ddbbe12-d1"
        Port "int-br-eth0"
            Interface "int-br-eth0"
        Port int-BRIDGE
            Interface int-BRIDGE
        Port br-int
            Interface br-int
                type: internal
    Bridge "br-eth0"
        Port "br-eth0"
            Interface "br-eth0"
                type: internal
        Port "phy-br-eth0"
            Interface "phy-br-eth0"
        Port "eth1"
            Interface "eth1"
    ovs_version: "1.10.0"

Then I created network and subnet using CLI

neutron net-create flat-50 --provider:network_type flat 

 neutron subnet-create flat-50 50.0.0.0/24

After this I have restarted all the services in controller and compute node. I could create VMs abut IPs are not getting assigned

edit retag flag offensive close merge delete

Comments

Would rename /etc/neutron/plugins/ml2/plugin.ini to /etc/neutron/plugins/ml2/ml2_conf.ini
Create soft link /etc/neutron/ml2_conf.ini to /etc/neutron/plugins/ml2/ml2_conf.ini
Create soft link /etc/neutron/plugin.ini to /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini

dbaxps gravatar imagedbaxps ( 2014-11-20 04:40:10 -0500 )edit

Can you manually assign IP to VM from 50.0.0.0/24 && and ping 8.8.8.8 ?

dbaxps gravatar imagedbaxps ( 2014-11-20 04:48:24 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-11-20 04:21:00 -0500

akshik gravatar image

have you checked for the creation of namespaces, if they are check the name spaces for the ip's getting created in that name space try to get the nova consoelog for the VM and check if there are any issues,

how about neutron log. did you managed to check them all, also ensure metadata agent is also running

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-02-10 03:20:59 -0500

Seen: 428 times

Last updated: Nov 20 '14