Linuxbridge router unable to ping gateway rocky

asked 2018-11-08 03:54:41 -0600

updated 2018-11-08 10:12:28 -0600

Hi, Details are :--

OS Used : Centos7
Nodes: 3 (Controller, Compute1 and block1)
MGMT: 172.20.30.0/27
Provider : 10.14.32.32/27

root@controller ~]# ip netns exec qrouter-4fd4304a-0db5-4a88-9602-f219e33ef4ce route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         10.14.32.62     0.0.0.0         UG    0      0        0 qg-26102b5f-f3
10.14.32.32     0.0.0.0         255.255.255.224 U     0      0        0 qg-26102b5f-f3

[root@controller ~]# ip netns exec qrouter-4fd4304a-0db5-4a88-9602-f219e33ef4ce ping 10.14.32.62
PING 10.14.32.62 (10.14.32.62) 56(84) bytes of data.

From 10.14.32.37 icmp_seq=1 Destination Host Unreachable

Neutron configs are pasted here

[root@controller ~]# egrep -v "^#|^$" /etc/neutron/plugins/ml2/linuxbridge_agent.ini 
[DEFAULT]
[agent]
[linux_bridge]
physical_interface_mappings = provider:ens192
[network_log]
[securitygroup]
firewall_driver = neutron.agent.linux.iptables_firewall.IptablesFirewallDriver
enable_security_group = true
[vxlan]
enable_vxlan = true
local_ip = 172.20.30.7
l2_population = true

[root@controller ~]# egrep -v "^#|^$" /etc/neutron/plugins/ml2/linuxbridge_agent.ini 
[DEFAULT]
[agent]
[linux_bridge]
physical_interface_mappings = provider:ens192
[network_log]
[securitygroup]
firewall_driver = neutron.agent.linux.iptables_firewall.IptablesFirewallDriver
enable_security_group = true
[vxlan]
enable_vxlan = true
local_ip = 172.20.30.7
l2_population = true

 Please help me why from qrouter unable to ping the gateway i.e 10.14.32.62 whish is configured on external 
 physical cisco switch.. 

[root@controller ~]# brctl show
bridge name     bridge id               STP enabled     interfaces
brqf994346a-f7          8000.000c29288950       no              ens192
                                                        tap1dbb259b-a9
                                                       tap26102b5f-f3
virbr0          8000.525400e0286e       yes             virbr0-nic

[root@controller ~]# ip a
2: ens192: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast master brqf994346a-f7 state UP 
group default qlen 1000
    link/ether 00:0c:29:28:89:50 brd ff:ff:ff:ff:ff:ff
3: ens224: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 00:0c:29:28:89:5a brd ff:ff:ff:ff:ff:ff
    inet 172.20.30.7/27 brd 172.20.30.31 scope global noprefixroute dynamic ens224
       valid_lft 77468sec preferred_lft 77468sec
    inet6 fe80::20c:29ff:fe28:895a/64 scope link 
       valid_lft forever preferred_lft forever
4: bond0: <BROADCAST,MULTICAST,MASTER> mtu 1500 qdisc noop state DOWN group default qlen 1000
link/ether a2:62:d3:bb:14:91 brd ff:ff:ff:ff:ff:ff
5: virbr0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default qlen 
1000
    link/ether 52:54:00:e0:28:6e brd ff:ff:ff:ff:ff:ff
    inet 192.168.122.1/24 brd 192.168.122.255 scope global virbr0
       valid_lft forever preferred_lft forever
6: virbr0-nic: <BROADCAST,MULTICAST> mtu 1500 qdisc pfifo_fast master virbr0 state DOWN group default qlen 
1000
    link/ether 52:54:00:e0:28:6e brd ff:ff:ff:ff:ff:ff
 26: tap1dbb259b-a9@if2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master 
brqf994346a-f7 state UP group default qlen 1000
    link/ether ee:04:00:bb:b3:12 brd ff:ff:ff:ff:ff:ff link-netnsid 0
 27: brqf994346a-f7: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default 
 qlen ...
(more)
edit retag flag offensive close merge delete

Comments

This is close to unreadable. Use the 101010 button to format your code.

Bernd Bausch gravatar imageBernd Bausch ( 2018-11-08 04:16:36 -0600 )edit

what is your linux bridg agent log?

novainfinite gravatar imagenovainfinite ( 2018-11-08 04:23:13 -0600 )edit

2018-11-08 13:33:23.611 1144 ERROR neutron.common.rpc [req-486c2a20-cf4c-4f25-afaf-9c1252029904 - - - - -] Timeout in RPC method get_service_plugin_list. Waiting for 35 seconds before next attempt. If the server is not down, consider increasing the rpc_response_timeout option as Neutron server(s) ma

Rajesh Kumar Chaturvedi gravatar imageRajesh Kumar Chaturvedi ( 2018-11-08 10:23:07 -0600 )edit