Ask Your Question
0

How to configure Devstack with Ceilometer, Gnocchi and Aodh components?

asked 2018-11-04 11:06:25 -0600

sharleen_go gravatar image

Hi, I've installed ceilometer, gnocchi and aodh components through devstack by adding the following lines in the local.conf described devstack installation guide.

enable_plugin ceilometer https://git.openstack.org/openstack/ceilometer stable/rocky
enable_plugin gnocchi https://github.com/gnocchixyz/gnocchi stable/4.2
enable_plugin aodh https://git.openstack.org/openstack/aodh

The installation finished without any errors; however, the output of gnocchi meter list is nothing. So, I think I'm missing something in the installation. In case this helps, the output of ps -ef | grep 'gnocchi' is as follows:

stack      927     1  0 Nov04 ?        00:00:04 /usr/bin/python /usr/local/bin/gnocchi-statsd -d --config-file /etc/gnocchi/gnocchi.conf
stack      946     1  0 Nov04 ?        00:00:00 gnocchi-metricd: master process [/usr/local/bin/gnocchi-metricd -d --config-file /etc/gnocchi/gnocchi.conf]
stack     2415  2410  0 Nov04 ?        00:00:06 (wsgi:gnocchi)    -k start
stack     2416  2410  0 Nov04 ?        00:00:05 (wsgi:gnocchi)    -k start
stack     2697   946  0 Nov04 ?        00:00:13 gnocchi-metricd: processing worker(0)
stack     2700   946  0 Nov04 ?        00:00:14 gnocchi-metricd: processing worker(1)
stack     2703   946  0 Nov04 ?        00:00:13 gnocchi-metricd: processing worker(2)
stack     2705   946  0 Nov04 ?        00:00:14 gnocchi-metricd: processing worker(3)
stack     2707   946  0 Nov04 ?        00:00:01 gnocchi-metricd: reporting worker(0)
stack     2709   946  0 Nov04 ?        00:00:02 gnocchi-metricd: janitor worker(0)

How do I even verify if gnocchi and ceilometer are configured correctly. Also, what is the proper way of easily installing these 3 components? Any help would be much appreciated. Thanks!

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
2

answered 2018-11-04 17:55:33 -0600

updated 2018-11-04 18:25:14 -0600

The command is metric list, not meter list. Your config looks good, except that you may want to add CEILOMETER_BACKEND=gnocchi, but perhaps that is the default anyway.

It looks like, by default, you need to be admin to show metrics. Don't ask my why.

Two days ago, I deployed a stable/rocky Devstack. My local.conf (password setting omitted):

$ cat devstack/local.conf
[[local|localrc]]

enable_service c-bak
enable_service swift

enable_plugin heat https://git.openstack.org/openstack/heat stable/rocky
enable_service h-eng h-api h-api-cfn h-api-cw

CEILOMETER_BACKEND=gnocchi
enable_plugin ceilometer https://git.openstack.org/openstack/ceilometer stable/rocky
enable_plugin aodh https://git.openstack.org/openstack/aodh stable/rocky

As demo, I can't list the metrics. As admin, I can:

stack@rocky:~$ . devstack/openrc demo demo
WARNING: setting legacy OS_TENANT_NAME to support cli tools.
stack@rocky:~$ gnocchi metric list

stack@rocky:~$ . devstack/openrc admin admin
WARNING: setting legacy OS_TENANT_NAME to support cli tools.
stack@rocky:~$ gnocchi metric list
+--------------------------------------+---------------------+--------------------------------------------+-----------+--------------------------------------+
| id                                   | archive_policy/name | name                                       | unit      | resource_id                          |
+--------------------------------------+---------------------+--------------------------------------------+-----------+--------------------------------------+
| 01090368-a664-4677-958f-3599879fba81 | low                 | storage.objects                            | object    | d6fe17c5-c064-425f-b788-d161ece31fad |
| 0b26c78b-fe3f-45a5-aba6-88fd0184c27e | low                 | volume.provider.capacity.total             | GB        | d152bac4-7a69-507a-9934-8a9468522ff6 |
(....)

Note that in order to limit the load, metric list only shows 50 metrics at a time. Use pagination to step through the entire list; the command line arguments are --marker and --limit.

edit flag offensive delete link more

Comments

Thank you so much for your local.conf file. In my initial configuration, I have not enabled swift so I think that's what caused my problem. The metric list is no longer empty. Again, thanks a bunch!

sharleen_go gravatar imagesharleen_go ( 2018-11-04 21:42:40 -0600 )edit

Glad I could help, but I wonder why? From my gnocchi.conf:

[storage]
coordination_url = redis://localhost:6379
redis_url = redis://localhost:6379
driver = redis

No trace of Swift.

Bernd Bausch gravatar imageBernd Bausch ( 2018-11-04 22:59:51 -0600 )edit

I'm not sure but I think it's ceilometer which requires swift, rather than gnocchi. In /etc/swift/proxy-server.conf ceilometer was referenced a couple of times. I'm not sure though..

sharleen_go gravatar imagesharleen_go ( 2018-11-05 02:56:16 -0600 )edit
0

answered 2018-11-04 16:39:26 -0600

novainfinite gravatar image

You should build an instance and set alarm for it. If you see insufficient data something is wrong but if you see ok or alarm everything is fine.

If you have problem what is your log in ceilometer and aodh.

I suggest you to use mongodb. Configure gnocchi is complicated.i know gnocchi is better and operational But mongodb is so simple.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-11-04 10:25:53 -0600

Seen: 64 times

Last updated: Nov 04