Ask Your Question
1

Host does not listen on Port 22

asked 2014-02-08 22:18:05 -0600

KMR gravatar image

updated 2014-06-06 16:44:10 -0600

smaffulli gravatar image
[root@localhost openstack]# packstack --answer-file /root/answers.txt
Welcome to Installer setup utility
Parameter CONFIG_MYSQL_HOST failed validation: Given host does not listen on port 22: 192.168.233.128

**ERROR : Failed handling answer file: Given host does not listen on port 22: 192.168.233.128**
Please check log file /var/tmp/packstack/20140209-092552-GZzhcP/openstack-setup.

Getting above error while running the packstack, I have tried in Fedora 20 and CentOS 6.5. In both I'm getting the same error. Please help if I need to do any changes on my answers.txt file

[general]

# Path to a Public key to install on servers. If a usable key has not
# been installed on the remote servers the user will be prompted for a
# password and this key will be installed so the password will not be
# required again
CONFIG_SSH_KEY=/root/.ssh/id_rsa.pub

# Set to 'y' if you would like Packstack to install MySQL
CONFIG_MYSQL_INSTALL=y

# Set to 'y' if you would like Packstack to install OpenStack Image
# Service (Glance)
CONFIG_GLANCE_INSTALL=y

# Set to 'y' if you would like Packstack to install OpenStack Block
# Storage (Cinder)
CONFIG_CINDER_INSTALL=y

# Set to 'y' if you would like Packstack to install OpenStack Compute
# (Nova)
CONFIG_NOVA_INSTALL=y

# Set to 'y' if you would like Packstack to install OpenStack
# Networking (Neutron)
CONFIG_NEUTRON_INSTALL=y

# Set to 'y' if you would like Packstack to install OpenStack
# Dashboard (Horizon)
CONFIG_HORIZON_INSTALL=y

# Set to 'y' if you would like Packstack to install OpenStack Object
# Storage (Swift)
CONFIG_SWIFT_INSTALL=n

# Set to 'y' if you would like Packstack to install OpenStack
# Metering (Ceilometer)
CONFIG_CEILOMETER_INSTALL=y

# Set to 'y' if you would like Packstack to install OpenStack
# Orchestration (Heat)
CONFIG_HEAT_INSTALL=n

# Set to 'y' if you would like Packstack to install the OpenStack
# Client packages. An admin "rc" file will also be installed
CONFIG_CLIENT_INSTALL=y

# Comma separated list of NTP servers. Leave plain if Packstack
# should not install ntpd on instances.
CONFIG_NTP_SERVERS=0.au.pool.ntp.org,1.au.pool.ntp.org,2.au.pool.ntp.org,3.au.pool.ntp.org

# Set to 'y' if you would like Packstack to install Nagios to monitor
# OpenStack hosts
CONFIG_NAGIOS_INSTALL=n

# Comma separated list of servers to be excluded from installation in
# case you are running Packstack the second time with the same answer
# file and don't want Packstack to touch these servers. Leave plain if
# you don't need to exclude any server.
EXCLUDE_SERVERS=

# The IP address of the server on which to install MySQL
CONFIG_MYSQL_HOST=192.168.233.128

# Username for the MySQL admin user
CONFIG_MYSQL_USER=root

# Password for the MySQL admin user
CONFIG_MYSQL_PW=905743c9fc8b4b95

# The IP address of the server on which to install the QPID service
CONFIG_QPID_HOST=192.168.233.128

# Enable SSL for the QPID service
CONFIG_QPID_ENABLE_SSL=n

# Enable Authentication for the QPID service
CONFIG_QPID_ENABLE_AUTH=n

# The password for the NSS certificate database of the QPID service
CONFIG_QPID_NSS_CERTDB_PW=95e182481f8e430ea846d5e03e9a9a54

# The port in which the QPID service listens to SSL connections
CONFIG_QPID_SSL_PORT=5671

# The filename of the certificate that ...
(more)
edit retag flag offensive close merge delete

Comments

where did you enter port 22 ? 22 is reserved for telnet. Avoid giving this port. Can you run the ifconfig command and ensure that above IP address is assigned ?

dheeru gravatar imagedheeru ( 2014-02-10 11:06:28 -0600 )edit

correction, port 22 is SSH.

gaud gravatar imagegaud ( 2014-03-05 17:51:47 -0600 )edit

3 answers

Sort by ยป oldest newest most voted
4

answered 2014-05-08 03:42:56 -0600

winter gravatar image

just start you sshd service will be helpful

edit flag offensive delete link more
1

answered 2015-03-29 12:41:45 -0600

harshalx gravatar image

Hello, I am installing RDO Juno on AWS RHEL 7 machine and I stumbled upon the exact same problems. The way I solve it was by not disabling the NetworkManager. There are 2-3 specific instructions during the start of the installation's Quickstart process. Ignore them and move along. It will work.

edit flag offensive delete link more
0

answered 2014-02-10 10:11:14 -0600

peruzzijl gravatar image

My guess, without seeing any logs, would be that you don't have IP address 192.168.233.128 bound to a network card on your host. I would suggest either adding a virtual interface with that IP or using a static IP on your client. What does your ifconfig show?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-02-08 22:18:05 -0600

Seen: 4,632 times

Last updated: Jun 06 '14