Ask Your Question

Could not connect to instance. Retrying.: ... [Errno 113] No route to host. provisioning_status stays on PENDING_CREATE

asked 2018-10-07 06:30:56 -0500

esxzawq gravatar image

updated 2018-10-07 13:46:55 -0500

hi all

I have configured an octavia service by help of Michael, but after creating loadbalancer the provisioning_status stays on PENDING_CREATE. the log of worker shows Could not connect to instance. Retrying.: ... [Errno 113] No route to hos

I have deployed openstack on virtualbox ( one vm for controller and one vm for compute) my network setting are :

2 vboxnet :

vboxnet1 : for provider network

vboxnet2 : for management network


and I have used linuxbridging.

in openstack I have created two network ( provider and selfservice)

provider :

selfservice :

after creating loadbalancer ( openstack loadbalancer create .... --vip-subnet-id selfservice) , it create the loadbalancer and wants to connect to the amphora instance with ip in range of that naturally does not have route to it , so provisioning_status stays on PENDING_CREATE ...

are my network configuration wrong !

should I use ovs instead of linuxbridging ! ...

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted

answered 2018-10-08 08:23:19 -0500

yasin lachiny gravatar image

i configure loadbalancer with linuxbridg and it does not have any problem. your load balancer should be provider that you can ping it from outside. openstack loadbalancer create .... --vip-subnet-id provider

you can use haproxy it is so simple

edit flag offensive delete link more


thank you I have tried this alos. the loadbalancer gets a provider ip but the instance gets the selfservice ip and loadbalancer stays on pending creat till it connect to the amphora

ctavia.amphorae.drivers.haproxy.rest_api_driver [-] Could not connect to instance. Retrying

esxzawq gravatar imageesxzawq ( 2018-10-08 14:27:19 -0500 )edit

answered 2018-10-29 13:31:01 -0500

johnsom gravatar image

Here are a couple of thoughts:

  1. VirtualBox is VERY slow to boot service VMs. I would check the nova console logs to make sure your service VM has finished booting. While it is booting, Octavia will keep retrying to connect with the above message.
  2. Octavia does not have any dependency on the neutron ML2 selection. Linux bridge and OVS both work just fine.
  3. This initial network connection from the Octavia worker process to the amphora is over the "lb-mgmt-net", which is a neutron network setup by the operator to handle the command/control traffic to/from the service VMs. It uses the network configured in the "[controller_worker]amp_boot_network_list" setting. Check that this network is the network you intend the controller processes to communicate with the amphora over.

I suspect the lb-mgmt-network is not setup correctly or the configuration has the wrong network ID in it.


edit flag offensive delete link more


I have put the amp_boot_network_list to the provider net ID and a sec group that all it's ports are open. due to qemu it takes long time to boot but the error changed to Could not connect to instance. Retrying.: SSLError: [SSL] PEM lib (_ssl.c:2554)

esxzawq gravatar imageesxzawq ( 2018-10-30 11:53:54 -0500 )edit

in fact the amphoa appears in openstack server list with an ACTIVE status but loadbalancer stock on PENDING_CREATE because of Retrying.: SSLError: [SSL] PEM lib (_ssl.c:2554)

esxzawq gravatar imageesxzawq ( 2018-10-30 12:40:09 -0500 )edit

Yes, ACTIVE in nova just means it started the hypervisor, it does not mean the virtual machine has booted successfully. For the SSL issue, I have commented on the other Ask OpenStack topic for that issue. Please see

johnsom gravatar imagejohnsom ( 2018-10-30 13:22:25 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2018-10-07 06:30:56 -0500

Seen: 836 times

Last updated: Oct 29 '18